Bug 215677 - Should anaconda-runtime require rhpl?
Summary: Should anaconda-runtime require rhpl?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-15 04:32 UTC by Mike McLean
Modified: 2008-04-21 15:44 UTC (History)
0 users

Fixed In Version: RHEL4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 15:41:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McLean 2006-11-15 04:32:59 UTC
rpm -qp --requires anaconda-runtime-10.1.1.46-1.i386.rpm 
libxml2-python  
python  
rpm-python >= 4.2-0.61
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

...but buildinstall blows chunks if rhpl isn't there

Traceback (most recent call last):
  File "<string>", line 1, in ?
ImportError: No module named rhpl.keyboard_models
/tmp/treedir.24014/instimage/usr/lib/anaconda-runtime/getkeymaps: line 45:
loadkeys: command not found

Comment 2 Mike McLean 2006-11-16 05:44:41 UTC
While we're on the subject, it looks like kdb is required as well (at least on
some arches).

Making images...
Running: /tmp/treedir.16914/instimage/usr/lib/anaconda-runtime/getkeymaps i386
/tmp/keymaps-i386.25856 /tmp/treedir.16914/instimage
find: /lib/kbd/keymaps/i386: No such file or directory
find: /lib/kbd/keymaps/i386: No such file or directory
...



Comment 4 Mike McLean 2006-11-16 05:57:18 UTC
...and dosfstools

Cleaning up images
/mnt/redhat/devel/mikem/trees/RHEL4-U5-re20061115.1/i386/i386-global/buildinstall.tree.16900/mk-images.i386:
line 196: mkdosfs: command not found
/mnt/redhat/devel/mikem/trees/RHEL4-U5-re20061115.1/i386/i386-global/images/diskboot.img:
This doesn't look like a FAT filesystem
/mnt/redhat/devel/mikem/trees/RHEL4-U5-re20061115.1/i386/i386-global/images/diskboot.img:
Sector sizes other than 512 not supported
mount: you must specify the filesystem type
umount2: Invalid argument

Comment 6 Jeremy Katz 2006-11-16 20:13:38 UTC
anaconda-runtime intentionally has absolutely minimal requirements to avoid
imposing requirements on people wanting to generate their own hdlists with
genhdlist.

Comment 7 David Cantrell 2007-03-15 22:09:53 UTC
(In reply to comment #6)
> anaconda-runtime intentionally has absolutely minimal requirements to avoid
> imposing requirements on people wanting to generate their own hdlists with
> genhdlist.

That's for the RHEL4 world, but is this something we should change for Fedora
and RHEL5?  Add those deps to the anaconda-runtime package?

Comment 8 Red Hat Bugzilla 2007-06-12 03:23:51 UTC
requested by Jams Antill

Comment 9 Joel Andres Granados 2008-04-21 14:45:36 UTC
Anaconda in RHEL4 already has dosfstools and rhpl in the requirements.
I this still an issue in the current builds?

Comment 10 Mike McLean 2008-04-21 15:44:52 UTC
long since worked around on my end.


Note You need to log in before you can comment on or make changes to this bug.