Bug 21573 - Installer does not detect duplicate LILO labels
Installer does not detect duplicate LILO labels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-01 02:04 EST by Stephen Rasku
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 15:34:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lilo.conf after upgrade to RH7 (267 bytes, text/plain)
2000-12-02 13:56 EST, Stephen Rasku
no flags Details
DIfferences from previous version of lilo.conf (592 bytes, patch)
2000-12-02 13:58 EST, Stephen Rasku
no flags Details | Diff

  None (edit)
Description Stephen Rasku 2000-12-01 02:04:19 EST
I just upgraded from 6.2 and 7.0 and modutils isn't finding modules.dep.  I see the following error in /var/log/messages:

    modprobe: modprobe: Can't open dependencies file /lib/modules/2.2.14-5.0/modules.dep (No such file or directory)

The specified directory doesn't exist but /lib/modules/{2.0.36-0.7,2.2.5-15,2.2.16-22}/modules.dep do exist.  /etc/issue says the kernel version 
is 2.2.14-5.0 but that doesn't exist on my system.  The release notes say that the kernel version is 2.2.16.  I don't know how it is deciding to 
search for 2.2.14-5.0.
Comment 1 Bill Nottingham 2000-12-01 11:45:52 EST
Something strange happened in your upgrade in that it's booting your
old kernel. Did you boot off an old bootdisk? What does your /etc/lilo.conf
say?

Assigining to the installer, since that's the most likely place this happened.
Comment 2 Stephen Rasku 2000-12-02 13:56:20 EST
Created attachment 5948 [details]
lilo.conf after upgrade to RH7
Comment 3 Stephen Rasku 2000-12-02 13:58:49 EST
Created attachment 5949 [details]
DIfferences from previous version of lilo.conf
Comment 4 Stephen Rasku 2000-12-02 14:06:52 EST
I have attached the lilo.conf created for RH7 as well as the differences from
the previous version.  When specifying the name for my other partition, I
changed it from "dos" to "nt".  This creates a duplicate label and LILO doesn't
like it.  It looks like the installer isn't smart enough to detect this problem.

When I removed the duplicate label, and re-ran lilo.  The computer booted fine.
Comment 5 Michael Fulbright 2000-12-04 13:59:09 EST
Was this a GUI or TUI install?
Comment 6 Stephen Rasku 2000-12-05 00:18:44 EST
GUI install.
Comment 7 Brent Fox 2000-12-29 01:41:55 EST
I have reproduced this bug and I'm looking into it further.
Comment 8 Brent Fox 2001-02-19 23:04:05 EST
Actually, the problem can be demonstrated in an even simpler way.  If you do an
install of RHL 7 and change the lilo label from 'linux' to something else, after
reboot you will have a lilo.conf file that has been concatenated to itself. 
This, of course, leaves you with an unbootable machine.
Comment 9 Brent Fox 2001-02-20 14:27:14 EST
Ok, for some reason I can't reproduce the behavior that I was seeing yesterday
with the exact same tree.
Comment 10 Brent Fox 2001-03-20 16:24:55 EST
The problem with upgrading the kernel version seems to be fixed.  However,
changing the dos label to something else, like 'windows' now results in
duplicate entries...that is, there's the original entry for
http://www.news.com/'dos' and a new one for 'windows'.  Lilo works fine with the
duplicate labels...it doesn't hurt anything, but it is annoying.  However, since
it isn't a critical bug, I'm reluctant to fix it at this point.  Deferring to a
future release.
Comment 11 Brent Fox 2001-03-20 16:40:13 EST
Uhh, I don't know what voodoo bugzilla did with my last post, but the hyperlink
in there was not supposed to be there.  What I meant was when you change the
label from dos to windows, you get an entry for both in the resulting lilo.conf
file.
Comment 12 Jeremy Katz 2002-02-15 14:28:10 EST
This should be fixed as of Red Hat Linux 7.2

Note You need to log in before you can comment on or make changes to this bug.