Bug 215740 - Frysk doesn't seem to handle debuginfo
Frysk doesn't seem to handle debuginfo
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: frysk (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Len DiMaggio
:
Depends On:
Blocks: 173278 218819
  Show dependency treegraph
 
Reported: 2006-11-15 10:23 EST by Alexander Larsson
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version: 0.0.1.2006.12.22.rh1-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 15:39:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
elfutils-java binding fix (684 bytes, patch)
2006-11-30 09:39 EST, Jan Kratochvil
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 3587 None None None Never

  None (edit)
Description Alexander Larsson 2006-11-15 10:23:54 EST
I'm using an up-to-date FC6, with nautilus-2.16.2-5.fc6 and
nautilus-debuginfo-2.16.2-5.fc6 installed (plus debuginfo for gtk2, glib2 etc),
and when i run "gdb nautilus" i get debug info.

However, when i start frysk and pick an existing nautilus process the stack
looks like its without debug info, and the source window says "Unknown File".

Frysk version is 0.0.1.2006.10.30.rh1-1.fc6
Comment 1 Andrew Cagney 2006-11-24 13:49:28 EST
Upstream bug: http://sourceware.org/bugzilla/show_bug.cgi?id=3587
Comment 2 Andrew Cagney 2006-11-29 19:40:30 EST
for the really simple:
  ftrace fstack $$
the log shows:

24664.24664 <SYSCALL> open ("/bin/bash.debug",32768,0)24664.24664  = -1 ERRNO=38
24664.24664 <SYSCALL> open ("/bin/.debug/bash.deb...",32768,0)24664.24664  = -1
ERRNO=38
24664.24664 <SYSCALL> open ("/usr/bin/debug/bin/b...",32768,0)24664.24664  = -1
ERRNO=38

and similarly:
  strace -s128 fstack $$
gets:

open("/bin/bash.debug", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or
directory)
open("/bin/.debug/bash.debug", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file
or directory)
open("/usr/bin/debug/bin/bash.debug", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such
file or directory)

adding a link:

$ sudo ln -s /usr/lib/debug/bin/bash.debug /bin
$ fstack $$
Task #15710
#0 0x1d2402 in __kernel_vsyscall ()
#1 0xca2479 in __waitpid_nocancel ()
#2 0x807a1bd in get_job_by_pid () from /usr/src/debug/bash-3.1/jobs.c
#3 0x807b288 in wait_for () from /usr/src/debug/bash-3.1/jobs.c
#4 0x806e34c in execute_command_internal () from
/usr/src/debug/bash-3.1/execute_cmd.c
#5 0x806ed83 in execute_command () from /usr/src/debug/bash-3.1/execute_cmd.c
#6 0x805e8c8 in reader_loop ()
#7 0x805e3c7 in main ()
#8 0xc2d4e4 in __libc_start_main ()
#9 0x805c021 in _start ()
Comment 3 Andrew Cagney 2006-11-29 19:42:28 EST
Roland,
Would Jan be able to help here?
Andrew
Comment 4 Jan Kratochvil 2006-11-30 09:39:22 EST
Created attachment 142478 [details]
elfutils-java binding fix

I believe the assigned Component should be `frysk', not Roland's `elfutils'.

Due to various resource circumstances I mostly cannot test it now.
Comment 5 Jan Kratochvil 2006-12-08 13:39:22 EST
[ RHEL5 Bug 218819 Copy ]

Bugfix (Bug 215740 Attachment 142478 [details]) has been verified on running
gaim-2.0.0-0.22.beta5.fc6.i386 with gaim-debuginfo-2.0.0-0.22.beta5.fc6.i386.
Verified on patched rebuilt: frysk-0.0.1.2006.12.01.rh1-2.i686
Without the fix:
#5 0x80b0719 in main ()
With the fix:
#5 0x80b0719 in main (): line #801

At least bash(1) does not benefit of its installed 'debuginfo' as it contains
its function symbols defined in `.dynsym'.

Still the backtrace information is sparse, at least on i686 (arguments missing),
it is not a scope of this Bug, though.
Comment 6 Jan Kratochvil 2006-12-24 08:35:06 EST
As the fix has been CVS committed upstream as:

2006-12-13  Jan Kratochvil  <jan.kratochvil@redhat.com>

        * cni/Dwfl.cxx (dwfl_begin): Fixed `debuginfo' files search path typo.

it is now a release engineering process.
Comment 7 Stepan Kasal 2007-01-03 15:39:43 EST
The fix is contained in version: 0.0.1.2006.12.22.rh1-1.fc6

Note You need to log in before you can comment on or make changes to this bug.