Bug 2157619 - [abrt] rocm-clinfo: llvm::report_fatal_error(): rocm-clinfo killed by SIGABRT
Summary: [abrt] rocm-clinfo: llvm::report_fatal_error(): rocm-clinfo killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 2156595
Alias: None
Product: Fedora
Classification: Fedora
Component: rocm-opencl
Version: 37
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Newton
QA Contact:
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5734aed035c50e1cea68dad0329...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-01-02 11:57 UTC by Chipeng Li
Modified: 2023-05-05 17:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-05 17:15:20 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (42.79 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: core_backtrace (20.37 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: cpuinfo (2.69 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: dso_list (556 bytes, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: environ (4.62 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: limits (1.29 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: maps (3.96 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: mountinfo (3.29 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: open_fds (1.10 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details
File: proc_pid_status (1.39 KB, text/plain)
2023-01-02 11:57 UTC, Chipeng Li
no flags Details

Description Chipeng Li 2023-01-02 11:57:27 UTC
Description of problem:
$ rocm-clinfo 
mesa: CommandLine Error: Option 'h' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
Aborted (core dumped)

Version-Release number of selected component:
rocm-clinfo-5.4.1-1.fc37

Additional info:
reporter:       libreport-2.17.4
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-org.gnome.Terminal.slice/vte-spawn-7f693fc2-17be-49b4-a567-b96a4b300cbd.scope
cmdline:        rocm-clinfo
crash_function: llvm::report_fatal_error
executable:     /usr/bin/rocm-clinfo
journald_cursor: s=6ebdcdc840d34de0ad96211b75d38e97;i=6abf6;b=ce2413e5a13a4b2381835f0ab0d942ed;m=72b682b0;t=5f1425c8c6b96;x=41250f584c08f2d7
kernel:         6.0.15-300.fc37.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 llvm::report_fatal_error at /usr/src/debug/llvm-15.0.6-1.fc37.x86_64/lib/Support/ErrorHandling.cpp:123
 #6 (anonymous namespace)::CommandLineParser::addOption at /usr/src/debug/llvm-15.0.6-1.fc37.x86_64/lib/Support/CommandLine.cpp:243
 #8 llvm::cl::Option::addArgument at /usr/src/debug/llvm-15.0.6-1.fc37.x86_64/lib/Support/CommandLine.cpp:447
 #9 llvm::cl::alias::alias<char [8], llvm::cl::desc, llvm::cl::aliasopt> at /usr/include/llvm/Support/CommandLine.h:1893
 #10 __static_initialization_and_destruction_0 at /usr/src/debug/rocm-compilersupport-5.4.1-1.fc37.x86_64/lib/comgr/src/comgr-objdump.cpp:180
 #11 _sub_I_65535_0.0
 #12 call_init at dl-init.c:70
 #14 _dl_init at dl-init.c:117
 #15 _dl_catch_exception at /usr/src/debug/glibc-2.36-8.fc37.x86_64/elf/dl-error-skeleton.c:182
 #16 dl_open_worker at dl-open.c:808

Comment 1 Chipeng Li 2023-01-02 11:57:30 UTC
Created attachment 1935280 [details]
File: backtrace

Comment 2 Chipeng Li 2023-01-02 11:57:35 UTC
Created attachment 1935281 [details]
File: core_backtrace

Comment 3 Chipeng Li 2023-01-02 11:57:36 UTC
Created attachment 1935282 [details]
File: cpuinfo

Comment 4 Chipeng Li 2023-01-02 11:57:37 UTC
Created attachment 1935283 [details]
File: dso_list

Comment 5 Chipeng Li 2023-01-02 11:57:38 UTC
Created attachment 1935284 [details]
File: environ

Comment 6 Chipeng Li 2023-01-02 11:57:39 UTC
Created attachment 1935285 [details]
File: limits

Comment 7 Chipeng Li 2023-01-02 11:57:40 UTC
Created attachment 1935286 [details]
File: maps

Comment 8 Chipeng Li 2023-01-02 11:57:41 UTC
Created attachment 1935287 [details]
File: mountinfo

Comment 9 Chipeng Li 2023-01-02 11:57:42 UTC
Created attachment 1935288 [details]
File: open_fds

Comment 10 Chipeng Li 2023-01-02 11:57:43 UTC
Created attachment 1935289 [details]
File: proc_pid_status

Comment 11 Jeremy Newton 2023-04-20 19:53:36 UTC
Does this resolve if you remove mesa-libOpenCL? If so, this is a duplicate of 2156595

Comment 12 Jeremy Newton 2023-04-22 00:30:02 UTC
So this should be fixed in this Fedora 37 update:
https://bodhi.fedoraproject.org/updates/FEDORA-2023-994e29c721

But in f38 there's a regression causing another similar yet unrelated issue, see RHBZ#2156595.
Please follow that issue if you've upgraded to Fedora 38.

Comment 13 Jeremy Newton 2023-05-05 17:15:20 UTC

*** This bug has been marked as a duplicate of bug 2156595 ***


Note You need to log in before you can comment on or make changes to this bug.