This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 215767 - automount[2281]: open_mount: (mount):cannot open mount module iso9660 (/usr/lib/autofs/mount_iso9660.so: cannot open shared object file: No such file or directory)
automount[2281]: open_mount: (mount):cannot open mount module iso9660 (/usr/l...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Kent
Brock Organ
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 12:16 EST by Orion Poplawski
Modified: 2008-04-03 22:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: autofs-5.0.2-28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 22:45:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-11-15 12:16:24 EST
Description of problem:

Seeing this in the log when there is an attempt to access /misc/cd:

automount[2281]: open_mount: (mount):cannot open mount module iso9660
(/usr/lib/autofs/mount_iso9660.so: cannot open shared object file: No such file
or directory)

The mount still succeeds, so the module appears unnecessary, but it would be
nice to avoid spurrious error messages.

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.22
Comment 1 Peter Bieringer 2006-12-06 09:08:26 EST
Same with mount_cifs.so: 

Dec  6 15:07:44 host automount[2140]: open_mount: (mount):cannot open mount
module cifs (/usr/lib/autofs/mount_cifs.so: cannot open shared object file: No
such file or directory)
Comment 2 Ian Kent 2006-12-06 09:28:21 EST
(In reply to comment #1)
> Same with mount_cifs.so: 
> 
> Dec  6 15:07:44 host automount[2140]: open_mount: (mount):cannot open mount
> module cifs (/usr/lib/autofs/mount_cifs.so: cannot open shared object file: No
> such file or directory)

Thanks for reminding me.
This had slipped my mind although I checked the code and
this is more of an informational message in this case than
an actual error.

I'm not sure yet the best way to deal with this because there
are situations where this message should be issued as an error.
I'll think about it a little more.

Ian
Comment 3 Peter Bieringer 2007-08-05 06:37:25 EDT
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242084 is probably a dup of
this one.
Comment 4 Orion Poplawski 2007-10-17 16:32:06 EDT
Still present, and still not a big deal.
Comment 5 Ian Kent 2007-10-17 21:12:38 EDT
(In reply to comment #4)
> Still present, and still not a big deal.

Yes, and I'm still not sure how to deal with it without
also stopping genuine error messages as well. Anyway it's
still on my list of things to do.
Comment 6 Bug Zapper 2008-04-03 14:38:25 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Orion Poplawski 2008-04-03 15:43:28 EDT
I'm not seeing this with /misc/cd in current rawhide or F8.  
Comment 8 Ian Kent 2008-04-03 22:45:19 EDT
Yes, that's right, it has been fixed.

Note You need to log in before you can comment on or make changes to this bug.