Bug 215802 - Thunar 0.5.0-0.1.rc2 will not run -- symbol lookup error
Thunar 0.5.0-0.1.rc2 will not run -- symbol lookup error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 15:28 EST by Joel Gomberg
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 21:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Gomberg 2006-11-15 15:28:28 EST
Description of problem:  

Thunar will not run.


Version-Release number of selected component (if applicable):

Thunar-0.5.0-0.1.rc2.fc6




How reproducible:

Attempt to run Thunar from a terminal.  It exits with this error message:

thunar: symbol lookup error: thunar: undefined symbol: 
exo_icon_view_set_enable_search

I suppose it could be an exo bug.  The exo version is exo-0.3.1.12-0.1.rc2.fc6

This problem is new with RC2.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Fenzi 2006-11-15 15:43:10 EST
Odd. I don't have a fc6 x86_64 box, but I do have a devel/rawhide one, and those
versions work just fine there. Additionally, it works fine with fc6/i386. 

Do you have the i386 or x86_64 or both versions installed?

What does: 

rpm -qa | egrep "Thunar|exo" 

return?

I'm getting someone with a x86_64 fc6 box to test further... 

Thanks for the bug report. 
Comment 2 Joel Gomberg 2006-11-15 17:07:59 EST
I only have the x86_64 version installed.

rpm -qa | egrep "Thunar|exo" returns:

exo-0.3.1.12-0.1.rc2.fc6
Thunar-0.5.0-0.1.rc2.fc6
Comment 3 Kevin Fenzi 2006-11-16 12:50:04 EST
Can you do a 'rpm -V exo Thunar' and see if there is any output? 

Also, does running a 'ldconfig' help any?

Comment 4 Joel Gomberg 2006-11-16 13:06:00 EST
1.  No output.

2.  No help from ldconfig.
Comment 5 Joel Gomberg 2006-11-16 13:37:43 EST
I downloaded your SRPM and tried to build exo using your spec file.  At the end
of the build process I received this error message:

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/exo-0.3.1.12-0.1.rc2-root-joel
error: Installed (but unpackaged) file(s) found:
   /usr/lib64/xfce4/mcs-plugins/exo-preferred-applications-settings.so


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib64/xfce4/mcs-plugins/exo-preferred-applications-settings.so

The referenced file does not exist on my machine.
Comment 6 Joel Gomberg 2006-11-16 16:24:29 EST
I downloaded the exo source from the xfce website and it compiled without any
problems and Thunar now works for me.  I'm still not sure what is causing the
problem with the RPM.
Comment 7 Kevin Fenzi 2006-11-16 17:13:07 EST
Looks like there is a requirements issue going on... exo Buildrequires:
xfce-mcs-manager-devel, which should require libxfcegui4-devel, but doesn't do
so, so it's not detecting the xfce-mcs-manager right on building exo. 

I will try and dig to the bottom of it tonight and get things updated. 

I'm still not sure it explains the error you were seeing though, it should just
mean that the exo-preferred-applications-settings.so doesn't get built, not a
missing symbol. 
Comment 8 Kevin Fenzi 2006-11-17 15:59:18 EST
I have updated the exo package, but it's not yet been pushed out. 
Can you try updating to that version once it's available and see if it works?

One possible cause for the error you were seeing occurred to me: 
Did you have another version of exo installed somewhere locally not in a rpm?
Ie, a /usr/local/lib/ version? Might Thunar have picked up on that and been
trying to use that? Of course if that was the case you might have overwritten it
with your new local version from comment #6. Do you have any backups of
/usr/local and/or think this might be the case?

You should be able to do a: 
ldd /usr/bin/Thunar | grep -i exo
to see what path the libexo that Thunar is using has. 

Comment 9 Joel Gomberg 2006-11-17 20:09:10 EST
ldd /usr/bin/Thunar | grep -i exo
        libexo-0.3.so.0 => /usr/local/lib/libexo-0.3.so.0 (0x00002aaaaad18000)

You may be right about this.  Between the time when xfce was dropped from the
core and picked up by extras, I did use the xfce graphic installer.  I also used
it to test the 4.4 betas and release candidates, although I used the installer
to uninstall them once I upgraded to fc6 and could get RC1 and then RC2 from
extras.  Somewhere along the line, I must have also compiled exo in order to use
the earliest versions of Thunar.  Again, I am quite sure that I did a make
uninstall on all these versions, but some libexo files are still in /usr/local/lib:

[root@alcibiades lib]# ls -l libexo*
-rw-r--r-- 1 root root 1934842 Nov 16 13:18 libexo-0.3.a
-rwxr-xr-x 1 root root     978 Nov 16 13:18 libexo-0.3.la
lrwxrwxrwx 1 root root      19 Nov 16 13:18 libexo-0.3.so -> libexo-0.3.so.0.3.1
lrwxrwxrwx 1 root root      19 Nov 16 13:18 libexo-0.3.so.0 -> libexo-0.3.so.0.3.1
-rwxr-xr-x 1 root root  486342 Jun 24  2005 libexo-0.3.so.0.0.0
-rwxr-xr-x 1 root root 4037506 Jan  5  2006 libexo-0.3.so.0.0.1
-rwxr-xr-x 1 root root  992501 Nov 16 13:18 libexo-0.3.so.0.3.1

As you can see, I've got a couple of libexo.so files from earlier versions, so
that could be the root of the problem.

I've just uninstalled the exo version that I installed yesterday.  I also
removed the remaining libexo files from /usr/local/lib.  Now Thunar works. 
Sorry to have taken up your time.  I do appreciate your quick responses.
Comment 10 Kevin Fenzi 2006-11-17 21:08:58 EST
Ah ha. Sorry I didn't think to have you check that sooner. 

On the plus side you got me to fix a bug in xfce-mcs-manager which affected exo. :) 

I am going to go ahead and close this bug for now... if you spot anything else,
feel free to re-open it or file a new bug. 

Thanks again for the bugreport. 

Note You need to log in before you can comment on or make changes to this bug.