Bug 2158021 - Update to 4.12 in EPEL9
Summary: Update to 4.12 in EPEL9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-importlib-metadata
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Frank Crawford
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-01-03 23:56 UTC by Jonathan Wright
Modified: 2023-09-19 04:32 UTC (History)
3 users (show)

Fixed In Version: python-importlib-metadata-4.12.0-2.el9
Clone Of:
Environment:
Last Closed: 2023-01-14 01:11:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jonathan Wright 2023-01-03 23:56:03 UTC
Can you please update EPEL9 to a build of 4.12?  It's needed so I can build RBTools 4.0 for EPEL9.

There don't appear to be any major backwards-incompatible changes and only 2 other packages depend on this.

# dnf repoquery --whatrequires python3-importlib-metadata
Last metadata expiration check: 2:22:02 ago on Tue Jan  3 21:29:41 2023.
python3-dns-lexicon-0:3.11.7-1.el9.noarch
python3-pytest-randomly-0:3.12.0-1.el9.noarch

I'm a maintainer of python3-dns-lexicon and I've confirmed it will be fine with the change.

python-pytest-randomly's setup.cfg cites this:
---
importlib-metadata >= 3.6.0 ; python_version < "3.10"
---

So it should not have any problems either.

Comment 1 Frank Crawford 2023-01-04 00:45:26 UTC
Okay, will take this and give it a go in the next few days.

Comment 2 Frank Crawford 2023-01-04 10:22:49 UTC
@jonathan A significant problem.  It requires setuptools >= 56 and currently RHEL9 only ships python3-setuptools-53.0.0-10.el9.noarch.

Until Red Hat upgrades to a later version we are stuck on importlib_metadata-4.6.3 as it requires setuptools >= 42.

Any suggestions?

Comment 3 Frank Crawford 2023-01-04 10:39:52 UTC
Sorry about the multiple needinfo.  I don't know what happened there.

Comment 4 Lumír Balhar 2023-01-04 13:07:23 UTC
I'd check whether the package really needs setuptools >= 56. Upstream devs sometimes higher these requirements without any significant reasons. We can either check the code upstream or remove the version limit and try to build it in COPR.

Comment 5 Frank Crawford 2023-01-04 23:48:51 UTC
Yeah, the version looks to be just the latest when they decided to upgrade from a much older version.

I'll try and zap version restriction and see if it builds.

Comment 6 Fedora Update System 2023-01-05 03:41:44 UTC
FEDORA-EPEL-2023-c611c3ea46 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-c611c3ea46

Comment 7 Frank Crawford 2023-01-05 03:45:16 UTC
A quick patch to lower the requirement to 53 seems to work fine, and still passes all the tests, so I've built it and pushed for review and eventual release.

Please test and confirm it is as you require.  I don't expect too much of an issue, as it is the same version as in F37.

Comment 8 Fedora Update System 2023-01-05 07:20:34 UTC
FEDORA-EPEL-2023-1ba70583f9 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-1ba70583f9

Comment 9 Fedora Update System 2023-01-06 00:28:48 UTC
FEDORA-EPEL-2023-1ba70583f9 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-1ba70583f9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-01-14 01:11:39 UTC
FEDORA-EPEL-2023-1ba70583f9 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Red Hat Bugzilla 2023-09-19 04:32:09 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 120 days


Note You need to log in before you can comment on or make changes to this bug.