Bug 215860 - invest-applet missing variation value
Summary: invest-applet missing variation value
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-16 01:48 UTC by clifford snow
Modified: 2008-03-18 18:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 18:42:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description clifford snow 2006-11-16 01:48:09 UTC
Description of problem:
The invest applet displays the ticker symbol, gain in value, percent gain, last
price but does not show the change in price from the previous close.  I believe
it is called variation in the code.

Version-Release number of selected component (if applicable):
gnome-applets-2.16.0.1-10.fc6

How reproducible:
Always

Steps to Reproduce:
1. right click and select Preferences
2.enter a validate stock symbol, number of shares, cost basis, and commision
and click Close.
3. click the pull down arrow on the applet.  
  
Actual results:
The following are displayed:
Symbol, gain, percent gain, and last price

Expected results:
The following should be displayed:
Symbol, gain, percent gain, last price, and Change from previous close

Additional info:

Comment 1 clifford snow 2006-11-27 00:32:41 UTC
I've been looking at the code - and I'm not a python person so please forgive my
lack of complete understanding.  I was wrong in my interpretation of what the
invest applet should display when there is the Amount field has a value > 0.  It
actually displays the values correctly.  I should have turned this in as a
request for a feature.  Sorry.

However, it appears that if you have 0 entered in Amount, invest-applet should
display the last price and the change since last open.  What it actuall displays
is the last price and the change in price with a percent (%) in quotes().  For
example,  
GOOG: +505.00 (-3.01%) 
What it should display is:
GOOG: +505.00 -3.01  
the stocked dropped $3.01, not 3.01%.

If I could make a request that the following be displayed when the amount > 0
Symbol: Current Price, Change, % Change, Total Value, % Value total Change
for example
GOOG: +505.00 -3.01 .59% 1000 + 25.3%

and for amount = 0
Symbol: Current Price, Change, % Change
for example
GOOG: +505.00 -3.01 .59%

Thanks,
Clifford

Comment 2 Ray Strode [halfline] 2008-03-18 18:42:00 UTC
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)


Note You need to log in before you can comment on or make changes to this bug.