Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
systemd provides the systemd-pstore service to manage oopses, dmesgs, and UEFI/ACPI messages written to ACPI/UEFI persistent storage area. Since that storage area is very small (10s of KiB), systemd-pstore is supposed to run on a successful boot, copy any data in the pstore to larger and longer term storage such as a disk drive, and clear the pstore for future use.
On RHEL-8, although there is an /etc/systemd/pstore.conf, the service does not seem to exist:
$ sudo systemctl status systemd-pstore
Unit systemd-pstore.service could not be found.
On Fedora 35, the services exists but is normally inactive:
$ sudo systemctl status systemd-pstore
○ systemd-pstore.service - Platform Persistent Storage Archival
Loaded: loaded (/usr/lib/systemd/system/systemd-pstore.service; enabled; vendor preset: enabled)
Active: inactive (dead)
Condition: start condition failed at Fri 2023-01-06 04:43:07 CST; 7h ago
Docs: man:systemd-pstore(8)
Jan 06 04:43:07 redhatnow systemd[1]: Condition check resulted in Platform Persistent Storage Archival being skipped.
Version-Release number of selected component (if applicable):
systemd-239.68.el8
How reproducible:
$ sudo systemctl status systemd-pstore
Actual results:
Unit systemd-pstore.service could not be found.
Expected results:
○ systemd-pstore.service - Platform Persistent Storage Archival
Loaded: loaded (/usr/lib/systemd/system/systemd-pstore.service; enabled; vendor preset: enabled)
> On RHEL-8, although there is an /etc/systemd/pstore.conf, the service does not seem to exist:
It doesn't. It was introduced in systemd 243. But it should be easy to backport.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (systemd bug fix and enhancement update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2023:2985
Description of problem: systemd provides the systemd-pstore service to manage oopses, dmesgs, and UEFI/ACPI messages written to ACPI/UEFI persistent storage area. Since that storage area is very small (10s of KiB), systemd-pstore is supposed to run on a successful boot, copy any data in the pstore to larger and longer term storage such as a disk drive, and clear the pstore for future use. On RHEL-8, although there is an /etc/systemd/pstore.conf, the service does not seem to exist: $ sudo systemctl status systemd-pstore Unit systemd-pstore.service could not be found. On Fedora 35, the services exists but is normally inactive: $ sudo systemctl status systemd-pstore ○ systemd-pstore.service - Platform Persistent Storage Archival Loaded: loaded (/usr/lib/systemd/system/systemd-pstore.service; enabled; vendor preset: enabled) Active: inactive (dead) Condition: start condition failed at Fri 2023-01-06 04:43:07 CST; 7h ago Docs: man:systemd-pstore(8) Jan 06 04:43:07 redhatnow systemd[1]: Condition check resulted in Platform Persistent Storage Archival being skipped. Version-Release number of selected component (if applicable): systemd-239.68.el8 How reproducible: $ sudo systemctl status systemd-pstore Actual results: Unit systemd-pstore.service could not be found. Expected results: ○ systemd-pstore.service - Platform Persistent Storage Archival Loaded: loaded (/usr/lib/systemd/system/systemd-pstore.service; enabled; vendor preset: enabled)