Bug 215891 - Graphical guest installation leads to mouse problems
Graphical guest installation leads to mouse problems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 03:55 EST by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 09:06:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2006-11-16 03:55:16 EST
Description of problem:
During the graphical console install of a Fedora Core 6 guest I have problems
with the mouse: it is almost impossible to hit the appropriate PushButtons in
the several anaconda windows leading through the installation.

Version-Release number of selected component (if applicable):
xen-3.0.3-0.1.rc3


How reproducible:
Each time

Steps to Reproduce:
1.Start the graphical installer of FC6
2.
3.
  
Actual results:
The mousepointer cannot be located on the installer screen

Expected results:
Correct mouse pointer

Additional info:
Comment 1 Stephen Tweedie 2006-11-16 11:25:02 EST
Please describe the problems.  We know that the mouse acceleration in the guest
windows is awkward, but your description doesn't give us any hint as to whether
that's what you're seeing or not.  Also, is this fully virtualised or
paravirtualised?
Comment 2 Joachim Backes 2006-11-17 01:42:14 EST
1. It's a paravirtalized guest system.
2. There are two mousepointers: The first one is the standard mousepointer of my 
   X11 desktop, and the second one belongs to the VNC windows. This second
   VNC pointer,
   which has each time a distance of 1-2 inches to my X11 mouse pointer,
   has problems to hit the push buttons: mostly, it is unable to move to the
   pushbuttons or near the boarder of the VNC window (it stops at a distance of
   about 1/2 inch to the pushbuttons).
Comment 3 Felix Schwarz 2006-12-01 13:44:22 EST
This seems to be the same issue as described in the Xen user manual ("usb
tablet"). What about these two lines in your guest configuration file
(/etc/xen/...):
usb=1
usbdevice='tablet'
Comment 4 Joachim Backes 2006-12-04 00:55:20 EST
root@xxx: grep usb /etc/xen/*
/etc/xen/xmexample.hvm:#usb=1
/etc/xen/xmexample.hvm:#usbdevice='mouse'
/etc/xen/xmexample.hvm:#usbdevice='tablet'
/etc/xen/xmexample.vti:#usb=1
/etc/xen/xmexample.vti:#usbdevice='mouse'
/etc/xen/xmexample.vti:#usbdevice='tablet'

No other file(s) containing "usb"!
Comment 5 Felix Schwarz 2006-12-04 01:16:33 EST
Please read "A.4.3 Mouse issues, especially under VNC" in the XEN user manual
(http://www.cl.cam.ac.uk/research/srg/netos/xen/readmes/user/user.html) and try
putting the options "usb", "usbdevice" in your configuration file. Does this
solve your problem?
Comment 6 Joachim Backes 2006-12-04 02:38:56 EST
yes.
Comment 7 Felix Schwarz 2006-12-07 08:30:34 EST
This is no bug which Redhat can fix. I suggest, you close it as NOTABUG or
WONTFIX. You may file a bug in the XEN bug tracker but as written in the user
manual, there seems to be no easy fix and a workaround is available, well known
and prominently documented.

Note You need to log in before you can comment on or make changes to this bug.