Bug 215939 - kernel dm: use private biosets to avoid deadlock under memory pressure
kernel dm: use private biosets to avoid deadlock under memory pressure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 08:42 EST by Milan Broz
Modified: 2013-02-28 23:04 EST (History)
14 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 00:08:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2006-11-16 08:42:15 EST
+++ This bug was initially created as a clone of Bug #209851 +++
RHEL4.5 clone

To avoid deadlock under memory pressure it is necessary for dm layers to use
private mempools and not share them.
Comment 1 RHEL Product and Program Management 2006-11-16 08:45:31 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Tom Coughlan 2006-12-08 17:46:25 EST
Milan,

Can you add some information about how common this problem is? Has it been seen
in the field? Typical workloads and configurations? Or strictly theoretical or
unrealistic configs?  

Tom
Comment 4 Milan Broz 2006-12-08 18:17:13 EST
This problem can only happen in low memory situations when higher level (fs or
upper stacked dm device) succesfully allocate bios but lower level does not
because of low memory (upper levels drain common memory pool).

I saw this problem upstream but actually have no reports in RHEL4 but it use
similar code...

There are no biosets in RHEL4 kernel so implementation will require backporting
of changes in block layer.
Comment 10 RHEL Product and Program Management 2006-12-14 08:31:17 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 Jay Turner 2007-01-02 08:47:31 EST
QE ack for RHEL4.5.
Comment 13 Jason Baron 2007-01-02 13:52:07 EST
committed in stream U5 build 42.36. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 16 Red Hat Bugzilla 2007-05-08 00:08:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.