Bug 215965 - Link /lib/modules/2.6.18-1.2849.fc6/build points to ../../../usr/src/kernels/2.6.18-1.2849.fc6-i586 instead of ../../../usr/src/kernels/2.6.18-1.2849.fc6-i686 and I cannot hardlink that directory.
Link /lib/modules/2.6.18-1.2849.fc6/build points to ../../../usr/src/kernels/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 11:44 EST by Mark
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 23:53:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2006-11-16 11:44:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
For some reason the installed link loacted at /lib/modules/2.6.18-1.2849.fc6/build points to ../../../usr/src/kernels/2.6.18-1.2849.fc6-i586 instead of /usr/src/kernels/2.6.18-1.2849.fc6-i686.  The interesting thing is the i586 kernel has never been installed.  (See bug reports on FC6 installing i586 kernel instead of the i686 kernel.)  I have tried removing the link and creating a new link with ln --directory /usr/src/kernels/2.6.18.1.2849.fc-i686 /lib/modules/2.6.18.1-2849.fc6 and it fails with ln: creating hard link `/lib/modules/2.6.18-1.2849.fc6/build' to `/usr/src/kernels/2.6.18-1.2849.fc6-i686/': Operation not permitted.  I can create a symbolic link, however, any builds (make) I do still fail.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2849.fc6

How reproducible:
Always


Steps to Reproduce:
ls -l /usr/modules/2.6.18-1.2849.fc6/build
2.
3.

Actual Results:
lrwxrwxrwx 2 root root 47 Nov 14 18:23 /lib/modules/2.6.18-1.2849.fc6/build -> ../../../usr/src/kernels/2.6.18-1.2849.fc6-i586

Expected Results:
lrwxrwxrwx 2 root root 47 Nov 14 18:23 /lib/modules/2.6.18-1.2849.fc6/build -> ../../../usr/src/kernels/2.6.18-1.2849.fc6-i686

Additional info:

Note You need to log in before you can comment on or make changes to this bug.