Bug 215976 - screen is blank after resume on Lenovo X60s (Intel 945GM/GMS/940GML graphics controller)
screen is blank after resume on Lenovo X60s (Intel 945GM/GMS/940GML graphics ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Cunningham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 12:40 EST by John Heidemann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-02 20:05:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
requested xorg.conf (1.03 KB, text/plain)
2006-12-29 13:11 EST, John Heidemann
no flags Details
requested Xorg.0.log (785.32 KB, text/plain)
2006-12-29 13:12 EST, John Heidemann
no flags Details
default autoconfigured xorg.conf (639 bytes, application/octet-stream)
2006-12-29 13:14 EST, John Heidemann
no flags Details

  None (edit)
Description John Heidemann 2006-11-16 12:40:21 EST
Description of problem:

Running stock FC6 with current patches.
After suspend-to-RAM and resume, 
the computer restarts fine, but the LCD screen is blank.
One can (typing blind) log in to a VC and reboot, 
but not get the screen back.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install FC6
2. Log in
3. Suspend to ram (via "echo mem >/sys/power/state")
4. Close lid
5. resume by opening lid
6. no display at all :-(
  
Actual results:

Blank screen after resume.

Expected results:

Happy X11 video, or even console video.

Additional info:

I tried several common work arounds:
- switching to a non-X virtual console before suspending
- switching to other VC then to X's VC after resuming

Not yet tried: booting with kernel option acpi_sleep=s3_bios

No luck.

Some additional documentation on 
http://www.thinkwiki.org/wiki/Problem_with_display_remaining_black_after_resume
and
http://www.thinkwiki.org/wiki/Category:X60s
Comment 1 John Heidemann 2006-11-16 12:54:47 EST
The "acpi_sleep=s3_bios" hack suggested on thinkwiki seems to succeed as a work
around (at least, from one quick try).

So the bug report should not be "doesn't work", but "black magic hack required
to make it work".
Comment 2 Matěj Cepl 2006-12-29 05:47:13 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 John Heidemann 2006-12-29 13:11:00 EST
Created attachment 144552 [details]
requested xorg.conf
Comment 4 John Heidemann 2006-12-29 13:12:28 EST
Created attachment 144553 [details]
requested Xorg.0.log
Comment 5 John Heidemann 2006-12-29 13:14:06 EST
Created attachment 144554 [details]
default autoconfigured xorg.conf

here is the autoconfigured xorg.conf
I no longer have a matching Xorg.0.log for it :-(
Comment 6 Nigel Cunningham 2007-01-03 06:01:31 EST
Could you please try the 915resolution tool? It should be able to get the 
video reset post-resume.
Comment 7 John Heidemann 2007-01-04 00:02:40 EST
Ok, I guess I can try 915resolution.  Except that it's not clear what that
means...the README with it says it overwrites video BIOS to particular
resolutions, but I already have the right resolutions in my BIOS.  It also says
it should be run in text mode, but I was running X when I suspended, and I don't
want to terminate X on resume (!).

Have you tried this, Nigel, and if so, do you have more specific advice about
how I should use 915resolution?
Comment 8 Nigel Cunningham 2007-01-04 16:53:46 EST
I haven't tried it because I don't have the appropriate chipset, but from what 
I understand, you should have an /etc/init.d/915resolution script.

When it says that it needs to be run in text mode, it just means you need to 
have switched vts away from X when it is run. So, I would make a test script 
along the following lines:

#!/bin/bash
chvt 1
echo mem > /sys/power/state
/etc/init.d/915resolution restart
chvt 7

If this gives you video back after the suspend to ram, then the 915resolution 
tool did the trick. If not, we need to keep looking :)
Comment 9 Nigel Cunningham 2007-03-18 18:01:14 EDT
Setting NeedInfo as no report received on whether the steps in comment 8 helped.
Sorry for not doing this earlier.
Comment 10 John Heidemann 2007-06-02 18:44:06 EDT
Please close this bug out since F7 is out with different problems.

I was not able to try 915resolution since acpi_sleep=s3_bios fixed the problem
adequately.

Thanks for your help, though, Nigel.
  -John
Comment 11 Nigel Cunningham 2007-06-02 20:05:01 EDT
Closing with resolution WONTFIX, as requested.

You're welcome.

Note You need to log in before you can comment on or make changes to this bug.