Bug 21598 - New 4.30-1.62 seems to create mbox files
New 4.30-1.62 seems to create mbox files
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-01 14:45 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-14 03:40:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-01 14:45:26 EST
In our setup we have a number of users who alternately use pine as well as
some pop client for their email.  Since upgrading our RH 6.2 pine package
to 4.30-1.62, these users are experiencing problems.

It appears that when you first run the new pine version for the frist time
that it moves your mail spool file into $HOME/mbox (as pine will do if mbox
already exists).  Of course, when people try to later pop their mail off
the server, they can't see their recent messages.

BUT, if you manually merge the mbox back into the spool file, and then
remove the mbox file, pine seems to forget that there was ever an mbox.

Is there some system-wide solution I can implement rather than manually
merging and deleting every time a user has this problem?  More importantly,
is there a way to keep pine from doing this?
Comment 1 chappa 2001-01-14 03:40:14 EST
  There's no perfect solution, you'll have to decide which sickness you want to
have.

  The symptom that you are describing means that the C-Client library, a tool
used to compile Pine, was compiled enabling the "mbox" file. If you are reading
mail from the spool (not from a server) you can stop Pine from moving mail
between the spool and the "mbox" file by adding "mbox" to the line
"disable-these-drivers" in your personal ".pinerc" file. If you want to do this
system-wide you would have to add this value in the file
/usr/local/lib/pine.conf. After you add this value to either one of those two
files, Pine will only read mail from the spool.

   If you decide to do that, then users who do have a "mbox" file will complain
that they lost their mail, since Pine won't see it again. You'll end up fixing
their accounts too.

   If your users have their INBOX in a server,  and read mail through an IMAP
connection, there's nothing you can do. Adding the above mentioned line to
either the system-wide pinerc or to your personal pinerc won't do any good. It
will be completely ignored, because the responsible of moving these messages
between the INBOX and "mbox" is not Pine, it is the server, and there's no way
at this time to tell the server to stop moving messages on a per user basis.

  In another words, there's no much you can do at this time. This is not a bug,
since the intended behavior is that "mbox is an INBOX access method", which is
perfectly accomplished as you can see. The real problem is that there is no
perfect solution available today.
Comment 2 Mike A. Harris 2001-01-26 20:52:34 EST
I have looked into this problem a fair bit, and discussed it with
Ed as well.  He has some interesting ideas that may or may not fix
the problem for you.  After looking deeper into the issue however,
it seems aparent to me that a fix would involve some IMHO major changes
to PINE and/or IMAP sources, which would in effect be a fork of the
pine source code, which _I_ would have to maintain.  If PINE were GPL,
or GPL compatible, then it could be considered, however I have no intent
on making Red Hat Linux's pine incompatible with all other existing PINE
implementations.  This problem is not specific to Red Hat Linux, and since
the code is not completely "open", it is out of our control.  I recommend
taking this up with the PINE development team, perhaps encouraging them
to relicense their code as GPL so that it is more flexible.

Good luck, and let me know how you fare with the pine folk.  Take care.

Note You need to log in before you can comment on or make changes to this bug.