Bug 215983 - sa-update requires additional perl modules (LWP, Archive::Tar)
sa-update requires additional perl modules (LWP, Archive::Tar)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
: 217613 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 13:12 EST by Dale Bewley
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 15:15:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Bewley 2006-11-16 13:12:37 EST
Description of problem:
Spamassassin includes /usr/bin/sa-learn which has unsatisfied
dependencies for perl-Archive-Tar and perl-libwww-perl. 

Should this be considered a bug? Is there a reason not to add these deps?

Version-Release number of selected component (if applicable):
spamassassin-3.1.3-1.fc5 

How reproducible:

Steps to Reproduce:
1. yum install spamassassin
2. /usr/bin/sa-learn
  
Actual results:

[root@noc yum.repos.d]# sa-update
Can't locate LWP/UserAgent.pm in @INC ...
[root@noc yum.repos.d]# yum -y install perl-libwww-perl
[root@noc yum.repos.d]# sa-update
Can't locate Archive/Tar.pm in @INC ...
[root@noc yum.repos.d]# yum -y install perl-Archive-Tar

Expected results:

[root@noc yum.repos.d]# sa-update
sa-update: importing default keyring to '/etc/mail/spamassassin/sa-update-keys'...

Additional info:
Comment 1 Theo Van Dinter 2006-11-16 13:50:55 EST
sa-learn has no such requirements.  As shown in your "actual results" section,
sa-update has extra requirements (all listed in the docs).

I think this has been addressed in other tickets, but the SA view point is that
sa-update is optional in 3.1, so the modules it requires are optional, so
they're not listed as requirements in our spec file.

ymmv.
Comment 2 Dale Bewley 2006-11-16 14:29:58 EST
Shoot! I'm sorry. I didn't mean to say sa-learn. I meant sa-update.

If because sa-update is considered optional you don't want to list the
requirements, I guess I can live with that.

Thanks
Comment 3 Warren Togami 2006-11-16 14:49:37 EST
For FC5 we considered sa-update to be optional, but FC6 has the requires added
making it mandatory. 
Comment 4 Jason Tibbitts 2006-11-28 18:04:00 EST
*** Bug 217613 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.