This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 215997 - incorrect permissions on dnszone.schema
incorrect permissions on dnszone.schema
Status: CLOSED DUPLICATE of bug 226982
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 13:51 EST by Steven Pritchard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 09:09:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bind.spec patch (844 bytes, patch)
2006-11-16 13:51 EST, Steven Pritchard
no flags Details | Diff

  None (edit)
Description Steven Pritchard 2006-11-16 13:51:41 EST
Description of problem:
OpenLDAP breaks with bind-sdb installed due to incorrect permissions on
/etc/openldap/schema/dnszone.schema.

-rw-r----- 1 root named  5114 Nov  3 09:55 dnszone.schema

All other schema are owned by root:root and are mode 644.

Version-Release number of selected component (if applicable):
bind-sdb-9.3.3-6.fc6

I'm attaching a patch against rawhide's bind.spec that should fix the problem.
Comment 1 Steven Pritchard 2006-11-16 13:51:54 EST
Created attachment 141401 [details]
bind.spec patch
Comment 2 Martin Stransky 2006-11-22 09:09:35 EST
added to CVS, thanks!
Comment 3 Adam Tkac 2007-02-05 10:31:40 EST
(In reply to comment #1)
> Created an attachment (id=141401) [edit]
> bind.spec patch
> 

Problem was that dnszone.schema was installed with %config instead
%config(noreplace). This is fixed now

*** This bug has been marked as a duplicate of 226982 ***

Note You need to log in before you can comment on or make changes to this bug.