Bug 216023 - Windows Network printer has to be power-cycled between print jobs
Windows Network printer has to be power-cycled between print jobs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 15:01 EST by john
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 10:11:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john 2006-11-16 15:01:09 EST
Description of problem:
CUPS set up to print to Canon BJC3000 on Windows ME PC on the local LAN. Printer
has to be power-cycled between print jobs or the job never gets printed, even
though it's shown as "submitted" to the printer. Windows side shows job
submitted to the printer, but printer doesn't print unless power-cycled. Will
even hang Windows print jobs if not power-cycled.

Using "foomatic/gimp-print-ijs" as driver.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Install Canon BJC3000 on Windows ME PC
2.Configure CUPS to print to shared Windows printer
3.Send multiple print jobs to shared windows printer
  
Actual results:
First job goes through fine, Subsequent jobs hang until printer is power-cycled.

Expected results:
All jobs should go through without having to power-cycle the printer.

Additional info:
Comment 1 Tim Waugh 2006-11-17 07:48:14 EST
Firstly I'd like to try to eliminate foomatic.  To do this, we'll need to switch
to the native CUPS gimp-print drivers.  Install the 'gimp-print-cups' package,
and then use system-config-printer (System->Administration->Printing).  Click on
the queue you are using and then click the 'Change' button to the right of 'Make
and Model'.

The manufacturer should be correct so click Forward, and then you should see
'BJC-3000' already selected.   Confusingly, the gimp-print-cups drivers for it
are listed under 'BJC 3000' (earlier in the list), so select that for the model
and then select 'C/bjc-3000.ppd.gz' for the driver.

Then click forward, select 'try to copy the option settings', and then click apply.

Now, does the modified queue show the same behaviour?
Comment 2 john 2006-11-17 09:47:20 EST
Unfortunately, I don't *have* an option for "bjc3000." I will try with
"foomatic: BJC-3000-bjc600.ppd" which is the only other option for driver. I did
search for "bjc-3000.ppd" and "bjc-3000.ppd.gz" on my system, but could not find
them. Can you advise where they should be?
Comment 3 john 2006-11-17 09:59:02 EST
Ok. Looks like it just didn't like that printer driver. I just re-read your
message and see that I overlooked the instruction to                           
                                                                               
                                                                               
                                                                install the
"gimp-print-cups" package. Even though the new driver works, I'll try the
gimp-print-cups package and see if that fixes it. In any event, I would
recommend marking this as "closed." Thanks for your help.
Comment 4 john 2006-11-17 10:11:12 EST
FWIW, installing "gimp-print-cups" results in a NEW manufacturer entry "CANON"
(all upper-case" and THAT is where the new drivers are found. I'm going to try
that and see if I can get better quality printing. Thanks for the help!
Comment 5 Tim Waugh 2006-11-17 10:31:02 EST
Okay, sorry about that.  I didn't spot that because I'm using a test version of
system-config-printer that merges upper- and lower-case manufacturers when they
are different.. :-/

I'd be very interested to know if the gimp-print-cups driver gives the same
symptom, because it will mean that we'll know if the problem comes from foomatic
or from gimp-print.

Note You need to log in before you can comment on or make changes to this bug.