Bug 216045 - gnome-screensaver only works a few hours
gnome-screensaver only works a few hours
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 17:24 EST by Steve
Modified: 2013-03-05 22:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 09:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (839 bytes, application/octet-stream)
2006-11-16 17:24 EST, Steve
no flags Details
gnome-screensaver log from a successfull activation (3.69 KB, text/plain)
2006-11-27 12:44 EST, Vladimir Florinski
no flags Details
gnome-screensaver log from a failed activation (3.18 KB, text/plain)
2006-11-27 12:44 EST, Vladimir Florinski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 355279 None None None Never

  None (edit)
Description Steve 2006-11-16 17:24:31 EST
Description of problem:
gnome-screensaver only works a few hours.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.1-2.fc6

How reproducible:
gnome-screensaver only works a few hours. after log out and re-login it works
again for a few hours.

Steps to Reproduce:
1. wait for the screensaver
2. (maybe) go to sleep
3. after a few hours the screensaver don't work anymore (only black screen)
4. log out
5. log in
6. the screensaver works again 
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve 2006-11-16 17:24:31 EST
Created attachment 141424 [details]
xorg.conf
Comment 2 James 2006-11-24 15:48:23 EST
I see this phenomenon too, just as described (sometimes within an hour). The
screen locks and goes black, but the saver itself doesn't kick in. The screen
doesn't switch off either. Restarting killall gnome-screensaver &&
gnome-screensaver restores the correct behaviour for a while.
Comment 3 Steve 2006-11-25 04:16:05 EST
i have found this error today:

libGL warning: 3D driver claims to not support visual 0x4b

mesa-libGL-6.5.1-8.fc6
mesa-libGLU-6.5.1-8.fc6
xorg-x11-drv-ati-6.6.3-1.fc6
Comment 4 Vladimir Florinski 2006-11-26 18:57:32 EST
Confirm bug as well. Occurs regardless of hardware (Nvidia and Intel tested) and
regardless of the screensaver used (non OpenGL ones have this too).
Comment 5 Vladimir Florinski 2006-11-27 12:44:22 EST
Created attachment 142189 [details]
gnome-screensaver log from a successfull activation
Comment 6 Vladimir Florinski 2006-11-27 12:44:52 EST
Created attachment 142191 [details]
gnome-screensaver log from a failed activation
Comment 7 Vladimir Florinski 2006-11-27 12:57:10 EST
I investigated this some more and found that the reason a screensaver theme does
not start is because the "throttled" flag is set in gs_manager.c. This is
evident from comparing the two logs that I attached. Whereas the successful
activation log shows that "job" (i.e., the actual process of the screensaver
animation) is started, the second log shows that the screensaver is "throttled"
and the job does not start. Now, it appears that the "throttled" flag is set by
gnome-power-manager after the sleep timeout has elapsed (this is set in the
Power Managment menu). After a computer was left idle for that period of time,
gnome-power-manager sends gnome-screensaver a D-BUS message telling it to stop
the animation (since the display is going to be put to sleep, so why waste CPU
cycles). But it seems that the power manager does not inform gnome-screensaver
when the display become active again (or perhaps, gnome-screensaver is not
listening).

I hope the above info will be useful for developers. A similar bug was reported
here:

http://www.mail-archive.com/desktop-bugs@lists.ubuntu.com/msg53003.html
Comment 8 Ray Strode [halfline] 2006-11-27 13:26:10 EST
Ah this is a known gnome-power-manager bug, let me look for the upstream report...
Comment 9 Ray Strode [halfline] 2006-11-27 13:35:12 EST
http://bugzilla.gnome.org/show_bug.cgi?id=355279
Comment 10 Ray Strode [halfline] 2006-11-27 13:53:00 EST
Hi guys,

Would you mind testing gnome-power-manager-2.16.0-4.fc6 which should appear in
updates-testing today or tommorow, or gnome-power-manager-2.17.2.1-2.fc7 which
should be in tomorrow's rawhide compose?
Comment 11 Vladimir Florinski 2006-11-28 21:57:53 EST
Tested with gnome-power-manager-2.16.0-4.fc6 and the problem is no longer there.
Comment 12 Steve 2006-12-01 04:02:44 EST
fixed in gnome-power-manager-2.17.2.1-2.fc7.

have to wait for gnome-power-manager-2.16.0-4.fc6 to be sure, i'v made an $
pkill gpm && gpm -m /dev/input/mice -t exps2...
Comment 13 Ray Strode [halfline] 2006-12-01 09:44:37 EST
great thanks guys for confirming both versions.

Note You need to log in before you can comment on or make changes to this bug.