Bug 216068 - Rhythmbox "watch library for new files" feature doesnt work
Rhythmbox "watch library for new files" feature doesnt work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On: 210650
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 22:26 EST by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-28 01:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-16 22:26:53 EST
+++ This bug was initially created as a clone of Bug #210650 +++

Description of problem:
the "watch library for new files" doesnt work.

Version-Release number of selected component (if applicable):
rhythmbox-0.9.5-4.fc6

How reproducible:
always

Steps to Reproduce:
1. try to delete / add files from / to the library folder
  
Actual results:
nothing happens with library source.

-- Additional comment from mbabej@redhat.com on 2006-10-25 10:13 EST --
Hm, just tried in Mayhem and its the *same* there.

-- Additional comment from mbabej@redhat.com on 2006-10-25 10:53 EST --
Added a reference to GNOME bug #346759, might be related to this

-- Additional comment from tjb@unh.edu on 2006-11-08 16:03 EST --
I rebuilt rawhide rhythmbox 0.9.6 in mock and while it seems to fix the file
watching, multimedia keys no longer work. Any fix on the horizon for FC6?

-- Additional comment from tjb@unh.edu on 2006-11-08 20:26 EST --
Tried the same 0.9.6 rpm I built for Comment #3 on my laptop and it worked fine.
Maybe it's all we need for fc6?

-- Additional comment from mclasen@redhat.com on 2006-11-16 22:24 EST --
Michal, can you please try the rhythmbox-0.9.5-7.fc6 that I have just pushed
into updates-testing ?


If test results from the fc6 update are positive, we should put the
fix into RHEL5 too
Comment 1 Alexander Larsson 2006-11-20 12:24:19 EST
Built as rhythmbox-0.9.5-7.el5
Comment 2 Nicole Dai 2006-12-12 04:50:43 EST
From the following testing, the bug was not reproduced in rhythmbox-0.9.5-4.fc6.
I am not sure if my testing steps are wrong. Matthias, could you pls take a look
at it? Thanks.

Retested the following steps with rhythmbox-0.9.5-4.fc6 on
RHEL5-Client-20061024.5 x86_64 system:
1. Launch rhythmbox by Applications -> Sounds & Videos -> Rhythmbox
2. Skip all steps in the wizard
3. In the Music Player window, highlight Library entry in the left panel
4. Click Music -> Import File, select a folder which contains track files
Result: the track was imported immediately.

5. Right-click the tracks in the Library -> Remove
Result: the track was removed successfully

Also tested the steps in rhythmbox-0.9.5-8.el5 on RHEL5-Client-20061207.0 and
the problem was not found.
Comment 3 Alexander Larsson 2006-12-13 05:19:47 EST
The bug was about external remove events. So, you have to remove the file in a
shell.
Comment 4 Nicole Dai 2006-12-15 05:40:08 EST
I tried the following steps with rhythmbox-0.9.5-8.el5 on RHEL5-Client-20061207.0:
1.In g-t, type gconftool-2 --recursive-unset /apps/rhythmbox
2.Launch rhythmbox by Applications -> Sounds & Videos -> Rhythmbox
3.In the Music library setup, specify a path for the libary, such as ~/music_lib
4.In g-t, try to add files to ~/music_lib and observe the library source by GUI
of rhythmbox
5.In g-t, try to remove files to ~/music_lib and observe the library source by
GUI of rhythmbox
Result:4&5 Nothing happened from GUI of rhythmbox. It looks it still has problem.
Hi Alexander, are my test steps right? could you pls take a look at it? Thanks.
Comment 5 Nicole Dai 2006-12-15 05:52:45 EST
Another finding: if restart rhythmbox after "In g-t, try to add files to
~/music_lib" or "In g-t, try to remove files to ~/music_lib", it will take effect.
Comment 6 Xiaohong Wang 2006-12-28 01:08:31 EST
Verified on RHEL5-Client-20061226.nightly with rhythmbox-0.9.5-8.el5, import and
delete files in Library works fine. So resolve this bug, if anybody could
reproduce it again, pls feel free to reopen it. 

Note You need to log in before you can comment on or make changes to this bug.