This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 216071 - FC6 system-config-lvm still uses ext2online
FC6 system-config-lvm still uses ext2online
Status: CLOSED DUPLICATE of bug 212161
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 23:04 EST by Steven Elliott
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 13:25:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Elliott 2006-11-16 23:04:46 EST
Description of problem:

On FC6 system-config-lvm does not allow ext3 filesystems on LVs to be expanded
because it wrongly assumes that ex2online is still used to expand online ext2/3
volumes.

Version-Release number of selected component (if applicable):
system-config-lvm-1.0.18-1.2.FC6

How reproducible:
Quite.

Steps to Reproduce:

1. Attempt to expand a LV that has an ext3 filesystem in it by clicking on the
"Edit Proprerties" button. 
2. Attempt to increasing the size.
  
Actual results:
system-config-lvm does not allow the volume to be expanded.

Expected results:
system-config-lvm does allows the volume to be expanded.

Additional info:
As of FC6 the online expanding functionality that was in ext2online has been
moved to resize2fs, but system-config-lvm still checks for the existence of
resize2fs to determine whether online expansion of ext2/3 is supported (see
section 7.3):
  http://video.linux-noob.com/screenshots/fedora/6/RELEASE_NOTES_en_US.html
Consequently all references to ext2online in system-config-lvm should be changed
to resize2fs.
Comment 1 Stanko Kupcevic 2006-11-17 13:25:44 EST

*** This bug has been marked as a duplicate of 212161 ***

Note You need to log in before you can comment on or make changes to this bug.