Bug 216075 - /etc/named.conf is not found
/etc/named.conf is not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 00:16 EST by Tamal Kanti Nath
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 05:25:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (711.63 KB, application/octet-stream)
2006-11-18 00:25 EST, Tamal Kanti Nath
no flags Details

  None (edit)
Description Tamal Kanti Nath 2006-11-17 00:16:05 EST
Description of problem:
I cannot start the named [bind] service because /etc/named.conf file was not found.

Version-Release number of selected component (if applicable):
bind-9.3.3-6.fc6
Comment 1 Martin Stransky 2006-11-17 16:17:47 EST
Could you please attach an output from /var/log/messages? (when named fails to
start)
Comment 2 Tamal Kanti Nath 2006-11-18 00:25:56 EST
Created attachment 141549 [details]
/var/log/messages
Comment 3 Joe Cooper 2006-11-26 01:55:46 EST
Regardless of the "won't start" behavior (which I'm not seeing on my system,
because I also installed caching-nameserver, which seems to provide a working
named.caching-nameserver.conf file), a default named.conf ought to be created,
but is not.  It is expected behavior for all services to have a starting
configuration file, and historically one has always existed after installation
of bind from every prior version of the RPM I've used.

I guess this is related to this changelog entry:

- fix bug 176388: named.conf is now never replaced by any RPM

Seems that named.conf is now also never created by any RPM.
Comment 4 Joe Cooper 2006-11-26 02:23:41 EST
Ok, I noticed that the messages file provided by reporter does not contain the
information requested.  So I've replicated his situation, and the result is:

[root@localhost ~]# service named start
Locating //etc/named.conf failed:
                                                           [FAILED]

Nothing happens in /var/log/messages, because the initscript detects the lack of
named.conf before it even gets a chance to try to start.

Installing the bind-chroot package changes the error from the initscript, but
only to reflect the /var/named/chroot//etc/named.conf path.
Comment 5 Martin Stransky 2006-12-06 04:37:15 EST
(In reply to comment #2)
> Created an attachment (id=141549) [edit]
> /var/log/messages

good point, have you installed the caching-nameserver package? If not you have
to create /etc/named.conf by hand or by some utility like system-config-bind. 


Comment 6 Martin Stransky 2006-12-06 04:42:13 EST
(In reply to comment #3)
> Regardless of the "won't start" behavior (which I'm not seeing on my system,
> because I also installed caching-nameserver, which seems to provide a working
> named.caching-nameserver.conf file), a default named.conf ought to be created,
> but is not.  It is expected behavior for all services to have a starting
> configuration file, and historically one has always existed after installation
> of bind from every prior version of the RPM I've used.

I've checked the bind package and there isn't any default /etc/named.conf so if
you don't install caching-nameserver named will not start. The question is if
it's right...
Comment 7 Martin Stransky 2006-12-06 05:25:50 EST
I've added a notice about it to bind init script.
Comment 8 Tamal Kanti Nath 2006-12-06 10:42:23 EST
$ rpm -ql caching-nameserver 
/etc/named.caching-nameserver.conf
/etc/named.rfc1912.zones
/usr/share/doc/caching-nameserver-9.3.3
/usr/share/doc/caching-nameserver-9.3.3/Copyright
/usr/share/doc/caching-nameserver-9.3.3/rfc1912.txt
/var/named/localdomain.zone
/var/named/localhost.zone
/var/named/named.broadcast
/var/named/named.ca
/var/named/named.ip6.local
/var/named/named.local
/var/named/named.zero

The package caching-nameserver do not contain any /etc/named.conf file. Perhaps,
/etc/named.caching-nameserver.conf is an alternative one.

As a novice, it is tough for me to create a configuration file rather than
editing one. For example, httpd.conf enables common configurations with default
values. Other rarely used configurations are commented out. Thus I can spend
more time on using a program rather than configuring it.
Comment 9 Martin Stransky 2006-12-07 02:56:16 EST
Right, /etc/named.caching-nameserver.conf should be used instead of
/etc/named.conf and it's designed to work out of the box...
Comment 10 Joe Cooper 2006-12-07 13:54:23 EST
Sure, this works, but it's just not historically sound, and it confuses users. 
People expect a default configuration file, named what the configuration file is
usually named (in this case named.conf).  It feels like a pretty major packaging
policy change, without a very good reason for it.

It also assumes that the only tools people are using to edit the BIND
configuration are the ones provided by Fedora.  All other tools expect a
named.conf file.
Comment 11 Martin Stransky 2006-12-08 03:08:26 EST
(In reply to comment #10)
> Sure, this works, but it's just not historically sound, and it confuses users. 
> People expect a default configuration file, named what the configuration file is
> usually named (in this case named.conf).  It feels like a pretty major packaging
> policy change, without a very good reason for it.
> 
> It also assumes that the only tools people are using to edit the BIND
> configuration are the ones provided by Fedora.  All other tools expect a
> named.conf file.

Okay, so how do you propose to solve it?

Note You need to log in before you can comment on or make changes to this bug.