Bug 216098 - Window close crashes browser; opens new window then it should not
Window close crashes browser; opens new window then it should not
Status: CLOSED DUPLICATE of bug 193274
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 04:16 EST by Johan E
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 11:15:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the behavior (190.83 KB, image/png)
2007-04-29 21:58 EDT, Joseph A. Farmer
no flags Details
Showing the window has no menu. (247.68 KB, image/png)
2007-04-29 22:00 EDT, Joseph A. Farmer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 418199 None None None Never
Mozilla Foundation 263160 None None None Never

  None (edit)
Description Johan E 2006-11-17 04:16:51 EST
Description of problem:
Sometimes when I click on a link it will open up a new window (this is on a link
that normally doesn't do that) and the content shows up in this. If I choose to
close this window it will close the other firefox window as weel, even if there
are several open tabs without confirmation dialog. Only way to close the new
window is to close the tab that opened it.

Version-Release number of selected component (if applicable):
firefox-1.5.0.8-1.fc6

How reproducible:
don't yet know what triggers this

Steps to Reproduce:
1.
2.
3.
  
Actual results:
A new window opens up

Expected results:
the page should be displayed in the tab


Additional info:
got the following plugin:
adblock
noscript
sage
google notebook
Comment 1 Jeff Garzik 2006-11-23 17:02:58 EST
This problem makes web surfing highly annoying.  Firefix is opening windows
unrequested quite often for me.  The windows have no decorations (scrollbars,
buttons etc.) of their own.  Further, closing the window itself crashes the
entire Firefox process.

The only way to get the window to go away is to click on the original Firefox
window, and close the tab.  SOMETIMES hitting reload will make the extra window
disappear, and reappear in the proper place.  Sometimes.

I have bumped up the severity because this hits me at least every 5-10 minutes
while actively browsing.
Comment 2 Alex W. Jackson 2007-01-12 00:43:39 EST
This still happens in firefox-1.5.0.9-1.fc6, and in firefox-1.5.0.9-1.fc5 (the
latter running on FC5) with NO extensions or plugins at all installed.  In my
case it usually doesn't start occuring until Firefox has been running for a
while, but once it occurs for the first time, it will then reoccur very
frequently until Firefox is completely closed and restarted.
Comment 3 Jeff Garzik 2007-01-12 02:19:43 EST
I wonder...  is everybody affected using the GNOME window manager?

Yesterday I had nearly half of an IRC channel's members complain about this
problem.  It's definitely widespread.  The only FC6 guy who didn't experience
this problem was running fvwm.  May or may not be a useful data point.
Comment 4 Johan E 2007-01-12 03:41:30 EST
Yes, using gnome window manager
Comment 5 Alex W. Jackson 2007-01-12 03:46:43 EST
I'm also using GNOME (Metacity).
Comment 6 Adam Bentitou 2007-03-03 04:32:12 EST
This bug still exists in firefox-1.5.0.10-1.fc6.
I get this behavior using the 32bit firefox on
an amd64 system, with KDE.
Furthermore, I noticed that if you use the new
window it sometimes reintegrates into the appropriate
tab.



Comment 7 Jeff Garzik 2007-03-03 04:37:22 EST
Yes, I see the same thing here:

* If I click on a link in the unrequested window, it sometimes reintegrates into
the proper window

* If I click on the tab where the window was /supposed/ to load, and then click
reload, sometimes the unrequested window reintegrates into the proper window.

* If I close tha tab in the main browser windows (not the unrequested window),
the unrequested window always disappears, without crashing the browser.

* If I try to close the unrequested window by clicking on the window manager "x"
decoration, the browser crashes

* If I ignore the unrequested window, and the tab where it should have been
rendered, I can surf other websites just fine.
Comment 8 Adam Bentitou 2007-04-12 19:18:55 EDT
By the looks of the _numerous_ bug reports upstream at mozilla, it seems this
has been hitting people for around three years!! 
It seems there has finally been a little progress in the last month or so:
https://bugzilla.mozilla.org/show_bug.cgi?id=263160

It's not entirely clear what the issue is yet but it has led to a gtk+ bug
report, http://bugzilla.gnome.org/show_bug.cgi?id=418199 , to which no one
has yet responded to, in about a month.

Perhaps if someone from redhat got involved things would move more quickly.

Also it sounds like a qt build of firefox would have helped too, but thats
another story.
Comment 9 Joseph A. Farmer 2007-04-29 21:58:19 EDT
Created attachment 153754 [details]
Screenshot of the behavior

Screenshot #1 of the behavior in progress.
Comment 10 Joseph A. Farmer 2007-04-29 22:00:29 EDT
Created attachment 153755 [details]
Showing the window has no menu.

Two screenshots is enough.  3 computers and all of them do this.  All are
running Gnome.	The behavior seems to be a "leak" that occurs when the hosting
site tries to open a popup.
Comment 11 Matěj Cepl 2007-05-26 11:15:55 EDT

*** This bug has been marked as a duplicate of 193274 ***
Comment 12 Emmanuel Kowalski 2007-11-23 10:09:48 EST
For what it's worth, this behavior which used to occur frequently on my
laptop (Dell D820, nVidia video, with nv driver) has happened since upgrading
to Fedora 8 with Firefox 2.x

Comment 13 Emmanuel Kowalski 2007-11-23 10:10:41 EST
Sorry, a bad typo in #12: this has _NOT_ happened since upgrading to F8.

Note You need to log in before you can comment on or make changes to this bug.