Bug 216119 - Duplex options for non-duplex-capable printer
Duplex options for non-duplex-capable printer
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2006-11-17 07:23 EST by Tim Waugh
Modified: 2009-10-22 11:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-10-22 11:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-11-17 07:23:15 EST
Description of problem:
The HP PSC 2210 Foomatic/hpijs PPD includes a duplex option even though this
model is not duplex-capable.

Version-Release number of selected component (if applicable):

How reproducible:
Comment 1 Tim Waugh 2007-05-09 11:36:02 EDT
For the PSC 2210 in particular there is no duplex unit available for the
printer, so the constraints should just be adjusted.

In general though, configuration parameters that need optional accessories such
as a duplex unit should use the InstallableOptions section of the PPD.
Comment 2 Tim Waugh 2007-05-09 12:26:24 EDT
Hmm, actually for the hpijs printers it looks like we don't get to "opt out"
individual models from duplexing without patching it in the spec file. :-(
Comment 3 Tim Waugh 2007-12-17 10:38:44 EST
Still occurs in Fedora 8.
Comment 4 Tim Waugh 2008-06-02 06:59:16 EDT
Still in Fedora 9.
Comment 5 Bug Zapper 2009-06-09 18:21:01 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 6 Tim Waugh 2009-06-10 04:31:02 EDT
Still in Fedora 11.
Comment 7 Tim Waugh 2009-10-22 11:41:54 EDT
The hpcups driver (the preferred driver) has 'Installable Option' for this.

Note You need to log in before you can comment on or make changes to this bug.