Bug 21614 - Cannot install RH7
Summary: Cannot install RH7
Status: CLOSED DUPLICATE of bug 18032
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-02 15:32 UTC by RM Crorie
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 17:00:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description RM Crorie 2000-12-02 15:32:23 UTC
Fails to install packages after formatting partitions...

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//Win95_C

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 John Gotts 2000-12-02 15:58:44 UTC
I got a similar, if not the same, error three times in a row until I deferred
adding my MS-DOS partition until after the installation.  I was trying to mount
it under /ms, but that may not matter.  Also, my entire Linux system consists of
1 partition.  Perhaps multiple-partition systems are broken?  (There appear to
be several duplicates of this bug in bugzilla.)  Also, fdisk with Red Hat 7.0
seems to imply that you can now boot Linux filesystems beyond 1024 cylinders. 
Well, you can, but you had better make a boot disk because you'll have to
manually add lba32 and rerun lilo post-install.

Comment 2 RM Crorie 2000-12-03 16:32:45 UTC
Thanks for the clue - I was getting confused, because I did manage to get one 
working install, then (because I was trying to work out what was happening) 
repeated the installs again but got the same problem again and again.

Why was this a clue?  Because that working install followed me forgetting to 
edit the Disk Druid table to iclude two FAT32 partitions with my Windoze stuff 
on them (Win95).  (I have three very small IDE drives - but size isn't 
everything...)  I remember that distinctly because for one horrible moment 
whilst looking at the Linux file manager I thought I had lost the two FAT32 
partitions (always automounted under RH6).  Errrr... of course they are backed 
up... :-)

I will see if this is repeatable.

Comment 3 Michael Fulbright 2000-12-04 17:00:36 UTC

*** This bug has been marked as a duplicate of 18032 ***


Note You need to log in before you can comment on or make changes to this bug.