Bug 216148 - kernel dm crypt: System freezes randomly
kernel dm crypt: System freezes randomly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 09:44 EST by Dominik Sandjaja
Modified: 2013-02-28 23:04 EST (History)
13 users (show)

See Also:
Fixed In Version: 2.6.19-1.2895.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 08:39:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg (19.99 KB, application/octet-stream)
2006-11-17 09:45 EST, Dominik Sandjaja
no flags Details
Output of lsc (6.44 KB, application/octet-stream)
2006-11-17 09:50 EST, Dominik Sandjaja
no flags Details
Output of lspci -v (6.44 KB, application/octet-stream)
2006-11-17 09:50 EST, Dominik Sandjaja
no flags Details
Xorg.0.log (95.83 KB, text/plain)
2006-11-17 09:52 EST, Dominik Sandjaja
no flags Details

  None (edit)
Description Dominik Sandjaja 2006-11-17 09:44:14 EST
Description of problem:
My system freezes randomly, the symptoms are exactly the same as described in
#213227. Except I do not have a ThinkPad.


Version-Release number of selected component (if applicable):
Linux assassini.dadadom.lan 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:45:28 EST
2006 i686 i686 i386 GNU/Linux

How reproducible:
Not reproducible. Sometimes the system freezes after four or five days,
sometimes it freezes after less then five minutes. Also - except for Gnome -
there is not one specific program running at the time of freeze.

Actual results:
Total system freeze, only a reset (power off actually, as the laptop doesn't
have a reset-button) helps. No login via SSH possible, no restart of X possible,
no change to another console possible, nothing.

Expected results:
No freezes ;)

Additional info:
I experienced problems with XFS when I installed FC5 (were known back then), so
I switched my home partition to JFS. Now I suspected JSF, so I switched to ext3,
so it's definitely not the filesystem. Sometimes the fan of the laptop is
running, sometimes it isn't. Sometimes the latest CPU-speed (as can be seen on
the applet in Gnome) shows 1.4 GHz, sometimes 600 MHz. Most of the times, the
HDD is stressed, but not always, also no signs of any error on that side in any
log (see attachments). It's also not related to any rpm-action.

I never tested it with no X running as I have no need for the computer then...
Comment 1 Dominik Sandjaja 2006-11-17 09:45:50 EST
Created attachment 141474 [details]
Output of dmesg
Comment 2 Dominik Sandjaja 2006-11-17 09:50:02 EST
Created attachment 141475 [details]
Output of lsc
Comment 3 Dominik Sandjaja 2006-11-17 09:50:06 EST
Created attachment 141476 [details]
Output of lspci -v
Comment 4 Dominik Sandjaja 2006-11-17 09:52:04 EST
Created attachment 141477 [details]
Xorg.0.log
Comment 5 Dominik Sandjaja 2006-11-17 10:33:15 EST
I also think that a memory or cpu-error can be ruled out as my windows on the
same machine never crashes - at least not due to memory or cpu errors... ;) So
overheating, etc. are most likely not a factor.
Comment 6 Dominik Sandjaja 2006-11-18 06:56:54 EST
I forgot to mention, that I encrypt swap and /home with cryptsetup-luks.
Investigating further into that direction, I found
http://article.gmane.org/gmane.linux.kernel.device-mapper.dm-crypt/1942/match=freezes
which may be related. I will try out the proposed workaround of renicing
kjournald and tell, whether it works.
Comment 7 Dominik Sandjaja 2006-11-18 09:39:34 EST
Didn't work, system froze again. I just saw, that the OP in the dm-crypt list
only had temporary freezes, mine are definitely not temporary...
Comment 8 Dominik Sandjaja 2006-11-23 09:09:34 EST
I pinpointed the problem to be with the encrypted partitions. After having
switched back to unencrypted /home and swap, no freeze happened. After four days
I tried encrypted swap again and the system froze on the next yum update (when
it swapped a lot). So I am certain that the problem lies somewhere within the
crypting-facility. Renicing kjournald - as stated in Comment #6 - did not help.

I cannot tell when this phenomenon appeared for the first time but I do know,
that there were kernels (back in FC5), where this problem did not occur!

Please close this bug or mark it as duplicate (maybe
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216371 ?). BTW, is anyone
actually reading this report, except for me?
Comment 9 Alasdair Kergon 2007-01-10 11:46:05 EST
Can you retest with the newest kernel?  (There've been some dm-crypt changes
recently that might have fixed it.)
Comment 10 Dominik Sandjaja 2007-01-10 14:32:22 EST
I tried encrypted swap with the latest kernel 2.6.18-1.2869_1.fc6.cubbi_suspend2
and it seems to work, I was at least not able to provocate a freeze, despite
sizing the laptop's memory down to 256 MB.

Just out of interest, which is supposed to be the relevant change in the kernel?
The only dm-crypt related entry I could find is in the changelog of 2.6.18.6:

commit 43e5eb5c8cd3194f747c0a82b9939bfc48f352c5
Author: Christophe Saout <christophe@saout.de>
Date:   Sat Dec 2 03:27:56 2006 +0100

    [PATCH] dm crypt: Fix data corruption with dm-crypt over RAID5

Well, IMHO this bug can be closed now. When I have some time, I will retest with
encrypted home.
Comment 11 Milan Broz 2007-02-05 08:39:16 EST
Closing this bug - there were changes in dm-crypt in recent kernels (spec. in
2.6.19 - workqueue changes) and comment #10 says it works already...

Please reopen this bug if you catch this problem again with new kernel, thanks.

Note You need to log in before you can comment on or make changes to this bug.