Bug 21618 - Update from 6.2->7.0: X login doesn't work anymore
Update from 6.2->7.0: X login doesn't work anymore
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-02 12:33 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 10:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-02 12:33:03 EST
I had a RedHat 6.2 with Helixcode gnome on it.
I upgraded to RedHat 7.0
Now, the graphical login doesn't work anymore.
It accepts the login, it accepts the password.
Apparently it validates it, because if I try a wrong password it says so 
immediately.
Then the login screen goes black, and then just reappears, as if nothing 
had happened.
Text login still functions correctly, though.
I thought it was related to bug: 11323, so I tried to change 
the "x:5:respawn" to "x:5:once" in inittab, but to no avail.
I looked at /var/log/messages: here's the printout when logging in with 
user michel:
Dec  2 14:48:32 orac PAM_unix[937]: (system-auth) session opened for user 
michel by (uid=0)
Dec  2 14:48:33 orac gdm[937]: gdm_slave_session_start: michel on :0
Dec  2 14:48:33 orac PAM_unix[937]: (system-auth) session closed for user 
michel
Dec  2 14:48:33 orac gdm[937]: gdm_auth_user_remove: /home/michel is not 
owned by uid 0.
Dec  2 14:48:33 orac gdm[937]: gdm_auth_user_remove: Ignoring suspiciously 
looking cookie file /home/michel/.Xauthority

Can anybody help me, because I need my graphical workstation?
Comment 1 Havoc Pennington 2000-12-04 11:18:30 EST
My guess is that some Helix package is still installed, colliding with the Red
Hat setup, or that a Helix package did something it shouldn't have that
interfered with the upgrade. In general we only support upgrades from Red Hat
packages though; there are just far too many versions of the Helix packages and
their packages do not follow our packaging guidelines. There is no way we can
reproduce or QA problems with the Helix packages.

As a solution, I would recommend looking for Helix packages (rpm -qa | grep
helix) and replacing them with the Red Hat packages if you find them; that may
work. Or you could install the Helix 7.0 packages (though keep in mind, the same
problem will exist on upgrade to future Red Hat versions).
Comment 2 Craig Lawson 2001-03-04 21:29:34 EST
  I have the same problem on my system. I updated from 6.1 -> 7.0, and my
symptoms match exactly what Michel describes. The graphical login is broken.
However, the window manager still works if you have logged in at a text prompt.
  I searched for Helix code as recommended by hp, but it seems that I don't have
any in my RPM database.
  Until I find the solution, I am using the following work around:
    1. Use Linuxconf to set your boot mode to "text".
    2. Reboot.
    3. Log in at the text prompt.
    4. Run "startx".
Comment 3 Craig Lawson 2001-06-03 20:23:52 EDT
I found the solution to my problem. Turns out that I had some files missing
from my /etc/X11 directory, and that some shell scripts did not have executable
permissions. The following were missing:
    /etc/X11/gdm/Sessions/Default
    /etc/X11/gdm/Init/Default
The following shell scripts did not have the executable permission set:
    /etc/X11/xdm/Xsetup_0 and Xsession

  How did this happen? Not sure. The 7.0 installer died a few times, so that
could have done it, but it died during other installs on other machines, and the
problem did not happen there (so I could just be lucky).
  What helped me debug this problem somewhat was to enable Gnome debug messages:
Edit /etc/X11/gdm/gdm.conf, [debug] section. Change "Enabled" to 1 (the default
is 0). Log output goes to /var/log/messages.

Note You need to log in before you can comment on or make changes to this bug.