Bug 216195 - Call to innetgr(3) segfaults
Call to innetgr(3) segfaults
Status: CLOSED DUPLICATE of bug 210862
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-11-17 13:40 EST by Volker Lendecke
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-17 14:56:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
example program (88 bytes, text/plain)
2006-11-17 13:40 EST, Volker Lendecke
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 4171 None None None Never

  None (edit)
Description Volker Lendecke 2006-11-17 13:40:55 EST
Description of problem:

The innetgr(3) function seems not to function properly.

Version-Release number of selected component (if applicable):


How reproducible:


#include <netdb.h>
int main(void)
        innetgr("deve", "foo", "testuser", NULL);

and run it.

Steps to Reproduce:
1. cc -o main main.c (where main.c is the program file above)
2. ./main
Actual results:
[root@dhcp246 ~]# ./main
Segmentation fault

Expected results:

No segfault, but a silent program exit

Additional info:

(gdb) run
Starting program: /root/main 
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xda8000

Program received signal SIGSEGV, Segmentation fault.
0x0025a893 in strdup () from /lib/libc.so.6
(gdb) bt
#0  0x0025a893 in strdup () from /lib/libc.so.6
#1  0x00701b5f in nis_list () from /lib/libnsl.so.1
#2  0x00b9362e in _nss_nisplus_setnetgrent () from /lib/libnss_nisplus.so.2
#3  0x002d5d05 in innetgr () from /lib/libc.so.6
#4  0x080483b9 in main () at main.c:4
Comment 1 Volker Lendecke 2006-11-17 13:40:55 EST
Created attachment 141512 [details]
example program
Comment 2 Jakub Jelinek 2006-11-17 14:56:41 EST

*** This bug has been marked as a duplicate of 210862 ***

Note You need to log in before you can comment on or make changes to this bug.