Bug 216232 - undefined symbols in compiz plugins
undefined symbols in compiz plugins
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-17 16:57 EST by Jarod Wilson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 22:53:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Undefined symbols in $libdir/compiz/lib*.so (30.63 KB, text/plain)
2006-11-17 16:57 EST, Jarod Wilson
no flags Details

  None (edit)
Description Jarod Wilson 2006-11-17 16:57:11 EST
Description of problem:
The compiz plugins are full of undefined symbols. The gl* ones can be resolved
by linking offending plugins against libGL.so. The rest... I dunno what they
should like against, looks like they may be compiz-specific symbols.

Version-Release number of selected component (if applicable):
compiz-0.0.13-0.32.20060817git.fc6.x86_64

How reproducible:
ldd -r /usr/lib64/compiz/lib*.so > /dev/null

Additional info:

The beryl packages I'm working on for Extras are similarly afflicted.
Comment 1 Jarod Wilson 2006-11-17 16:57:11 EST
Created attachment 141537 [details]
Undefined symbols in $libdir/compiz/lib*.so
Comment 2 Kristian Høgsberg 2007-03-28 22:53:58 EDT
This isn't a problem.  They're plugins, not shared libraries.  The process
dlopening the .so files (compiz) is responsible for providing the unresolved
symbols, which it does by either 1) linking to libGL or other libraries to
provide the gl* symbols or 2) by exposing it's own internal API to the modules
which provides the remaining symbols.

Unresolved symbols are only a problem for shared libraries in /usr/lib that apps
actually link against.  In this case an unresolved symbol in a library will
prevent the application from running.

PS: try ldd -r on any .so file in /usr/lib/xorg :)
Comment 3 Jarod Wilson 2007-03-29 09:24:30 EDT
Ah, okay, works for me, you definitely know better than I do. I have the
misfortune of the being the sucker that maintains the beryl bits in fedora
extras, and has someone file a similar bug report for beryl. Saw the same
w/compiz, so that's where this bug came from. I'll close the one filed against
beryl too then. Thanks! :)

Note You need to log in before you can comment on or make changes to this bug.