Bug 216248 - --colour-blind option does not work
--colour-blind option does not work
Product: Fedora
Classification: Fedora
Component: frozen-bubble (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-11-17 18:31 EST by Roland Hermans
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.1.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-30 10:40:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
tarbal with missing images (7.90 KB, application/octet-stream)
2006-11-18 04:44 EST, Hans de Goede
no flags Details

  None (edit)
Description Roland Hermans 2006-11-17 18:31:29 EST
Description of problem:
Frozen Bubble doesn't initialize properly when using the --colour-blind option

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. enter "frozen-bubble --colour-blind" on the command line
Actual results:
[SDL Init] [Graphics.FATAL: Couldn't load
'/usr/share/frozen-bubble/gfx/balls/bubble-colourblind-1-mini.png' into a

Expected results:
Frozen Bubble uses bubbles with little geometrical symbols inside.

Additional info:
This problem appears to be present in upstream version as well. I tried to
contact upstream via theh e-mail address mentioned on the troubleshooting page
of the website http://www.frozen-bubble.org/ but the e-mail bounces with
"Relaying not allowed" error.
Comment 1 Hans de Goede 2006-11-18 04:43:10 EST
Reassigning to Matthias as he is the new frozen-bubble package maintainer.

Matthias, I'll update owners.list for this and put myself in the initial-CC as

I've taken a quick look and the problem seems to be that frozen-bubble tries to
open /usr/share/frozen-bubble/gfx/balls/bubble-colourblind-1-mini.png, which we
do not have, we only have bubble-colourblind-1.gif, but no matching
bubble-colourblind-1-mini.png, whereas the non colourblind version has both:
bubble-1.gif and bubble-1-mini.png .

I've rescaled the colourblind images and hand touched up (pixelated) the result. 
I'll attach a tarbal with them here. FE CVS is currently down, so actually
pushing out a fixed version may take some time. In the mean time unpack the
attached tarball in /usr/share/frozen-bubble/gfx/balls and all should be well.

Matthias, will you do the further fixing once CVS is up, or shall I? And could
you please send the tarbal to upstream? Thanks.

Comment 2 Hans de Goede 2006-11-18 04:44:41 EST
Created attachment 141552 [details]
tarbal with missing images
Comment 3 Roland Hermans 2006-11-19 19:44:03 EST
Thanks for the quick response. I extracted the files from the tar file and
Frozen Bubble now works OK with the --colour-blind option.
Comment 4 Matthias Saou 2006-11-20 06:42:38 EST
FYI, upstream has already solved the problem, so it will be fixed in the next
maintenance release. No ETA yet, sorry.
Comment 5 Matthias Saou 2006-11-30 10:40:40 EST
The 2.1.0 update has been pushed today. The option is now working.

Note You need to log in before you can comment on or make changes to this bug.