Bug 216273 - Default transparency of gnome-terminal makes the application unusable
Default transparency of gnome-terminal makes the application unusable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 09:59 EST by W. Michael Petullo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 13:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This isn't too bad... (341.40 KB, image/png)
2006-11-18 09:59 EST, W. Michael Petullo
no flags Details
...but I can't see this. (286.95 KB, image/png)
2006-11-18 10:00 EST, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2006-11-18 09:59:20 EST
Description of problem:
The default transparency of gnome-terminal (even though gnome-terminal is
configured to use a solid color background) renders the terminal unusable.

Version-Release number of selected component (if applicable):
compiz-0.0.13-0.32.20060817git.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Enable compiz's effects
2. Open gnome-terminal and another application
  
Actual results:
If the gnome-terminal is above the other application, then the gnome-terminal is
very difficult to see.  This is especially true if the application has a lot of
white in its window.

Expected results:
The text displayed by gnome-terminal should always be legible.

Additional info:
I am using a PowerPC iBook.  X identifies my video card as an "ATI Technologies
Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)]."
Comment 1 W. Michael Petullo 2006-11-18 09:59:20 EST
Created attachment 141554 [details]
This isn't too bad...
Comment 2 W. Michael Petullo 2006-11-18 10:00:45 EST
Created attachment 141555 [details]
...but I can't see this.
Comment 3 k3dzngrp8w2xtc9 2007-01-12 18:24:30 EST
Here gnome-terminal is not transparent at all by default.
Comment 4 Kristian Høgsberg 2007-03-28 22:21:25 EDT
This looks like a big-endian problem, there's number of places we could get this
wrong.  Let me see if I can get a PPC machine and reproduce the problem - and it
is a bug, we'd never set the default transparency to "unusable" :)
Comment 5 Kristian Høgsberg 2007-04-16 13:47:04 EDT
Just tested this on a PPC laptop and I don't see these problems.  If this is
still a problem with 0.3.6, please reopen this bug.
Comment 6 W. Michael Petullo 2007-07-11 14:01:04 EDT
I just confirmed that this is fixed in Fedora 7.

Note You need to log in before you can comment on or make changes to this bug.