Bug 216288 - weird strings added that breat my xorg.conf
weird strings added that breat my xorg.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pyxf86config (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 14:43 EST by Chris Petersen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 12:04:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Petersen 2006-11-18 14:43:47 EST
Reference original bug, which I thought was caused by livna's nvidia driver package:

https://bugzilla.livna.org/show_bug.cgi?id=1103

Every time I boot, what I assume is a livna-provided script checks for
availability of the drivers.  Part of this is to run an script which apparently
uses pyxf86config, and for some reason adds stuff like the following to my
xorg.conf file:

 ### Comment all HorizSync and VertSync values to use DDC:

Notice the leading space.  This breaks xorg.conf.  It also adds one or two of
these lines every time the script is run, so that after a couple of weeks of
daily booting, my xorg.conf file is littered with crap.  (I won't even go into
concerns about how it f*s up my hand-formatted xorg.conf file)

Livna has declared that this is not a bug in their
/usr/sbin/nvidia-config-display script, so I am just pushing this bug along to
the next piece of the puzzle.  I *did* check that the string is present in
ixf86configmodule.so.
Comment 1 Adam Jackson 2006-12-05 12:04:43 EST
Fixed in rawhide shortly, will do FC6 update too.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.