This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 216311 - emacs (including emacs -nw) VERY slow on startup
emacs (including emacs -nw) VERY slow on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-18 23:38 EST by Wolfgang Korsch
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 10:20:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Korsch 2006-11-18 23:38:48 EST
Description of problem: after new installation of FC6 emacs *with or without*
X starts up extremely slow. So slow that it is pretty much unusable.
This is new. I have been using Fedora since its first release and new had this
problem before. I really need emacs to work properly.
I found on the web to add

(modify-frame-parameters nil '((wait-for-wm . nil)))

to .emacs. This does not solve the problem 


Version-Release number of selected component (if applicable): 21.4-17


How reproducible: always


Steps to Reproduce: 
1. emacs
2. emacs filename
3. emacs -nw filename
  
Actual results: takes more than 30 seconds to start (in X mode and in no-X
mode)


Expected results: starts within ~1s


Additional info: this is new in FC6
Comment 1 Chip Coldwell 2006-11-20 09:38:26 EST
(In reply to comment #0)
> Description of problem: after new installation of FC6 emacs *with or without*
> X starts up extremely slow. So slow that it is pretty much unusable.

> Version-Release number of selected component (if applicable): 21.4-17

Does emacs 22 have the same problem?  You can get rpms from

http://people.redhat.com/coldwell/bugs/emacs/176171/FC-6/

Chip
Comment 2 Wolfgang Korsch 2006-11-26 23:25:19 EST
Hi,
 me again. I thought the bug was fixed this week after an X (x-server, ..) 
update that was released. However, it seems to be back. It worked for several
days. This is quite annoying. It comes and goes.

Wolfgang
Comment 3 Wolfgang Korsch 2006-12-02 11:56:43 EST
Ok, what I noticed is that the speed seems to be related to the WEP key enabled
wireless networking. Whenever I start emacs (X or no-X mode) with
wireless and WEP key enabled it's slow. On a nework w/o WEP key it's
fine. Is there anywhere a selinux or firewall switch/flag I need to
change for emacs?

Thanks,
 Wolfgang
Comment 4 dann 2007-02-27 13:05:13 EST
(In reply to comment #3)
> Ok, what I noticed is that the speed seems to be related to the WEP key enabled
> wireless networking. Whenever I start emacs (X or no-X mode) with
> wireless and WEP key enabled it's slow. On a nework w/o WEP key it's
> fine. Is there anywhere a selinux or firewall switch/flag I need to
> change for emacs?

Can you try reproducing your problem using 
emacs -q --no-site-file

if that is also slow, can you also try emacs-22 which is available for FC-5 and
FC-6 at: http://people.redhat.com/coldwell/emacs/fedora/

You can try to identify where the slowdown is comming from by running strace...
Comment 5 Wolfgang Korsch 2007-04-06 21:39:00 EDT
This problem was fixed within the last two weeks or. One of the more recent
upgrades did fix the problem. Which one? I wish I new. This problem had been
bothering me for several months. Unfortunately, I have no idea how the problem
was fixed. Sorry.
Thanks for all the suggestions,
Wolfgang


Comment 6 s4076743 2007-05-24 08:55:32 EDT
Had this problem with CD install of Fedora Core 6 with current updates. 

Emacs file emacs-21.4/etc/PROBLEMS lists:

>>* Emacs startup on GNU/Linux systems (and possibly other systems) is slow.
>>
>>This can happen if the system is misconfigured and Emacs can't get the
>>full qualified domain name, FQDN.  You should have your FQDN in the
>>/etc/hosts file, something like this:
>>
>>127.0.0.1	localhost
>>129.187.137.82	nuc04.t30.physik.tu-muenchen.de	nuc04

Problem was fixed by editing /etc/hosts to include a line
xxx.xxx.xxx.xxx  computername.localdomain

Note You need to log in before you can comment on or make changes to this bug.