Bug 216312 - Summary: kernel Oops when mounting CD-ROM as user
Summary: kernel Oops when mounting CD-ROM as user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2006-11-18 23:42 EST by Trevin Beattie
Modified: 2008-01-09 21:37 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.18-1.2850
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 21:37:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevin Beattie 2006-11-18 23:42:54 EST
Description of problem:
I just added a couple of lines to my /etc/fstab file in order to let me manually
mount CD's without having to switch to root:

/dev/hda                /mnt/cdrom1             autofs  noauto,user,ro  0 0
/dev/hdb                /mnt/cdrom2             autofs  noauto,user,ro  0 0

The trouble is that when I try to "mount /mnt/cdrom1" (using a FC6 SRPM CD), the
computer locks up.  I can ping it from another machine, but there is no response
from the console, and I can't ssh in.

The first time this happened I didn't see anything in the system log to indicate
what the problem was.  The second time I found the following message:

ov 18 19:53:00 hydra kernel: autofs: called with bogus options
Nov 18 19:53:00 hydra kernel: Unable to handle kernel NULL pointer dereference
at 0000000000000070 RIP: 
Nov 18 19:53:00 hydra kernel:  [<ffffffff88626793>]
:autofs4:autofs4_kill_sb+0x40/0xfd
Nov 18 19:53:00 hydra kernel: PGD 6fad9067 PUD 6e487067 PMD 0 
Nov 18 19:53:00 hydra kernel: Oops: 0000 [1] SMP 

First, I don't understand what autofs is complaining about.  I double-checked
the mount(8) man page, and noauto, user, and ro are all valid options.

Second, even if I did have bad options in /etc/fstab I don't think that should
cause a kernel crash!


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2798.fc6.x86_64

How reproducible:
Three crashes out of three attempts.  Previously I had been letting nautilus
auto-mount the drives, and most of the time it worked fine, though sometimes it
simply did nothing.  In the latter case I'd have to mount the drive manually, as
root, using "mount -o ro /dev/hda /mnt/cdrom1", and that worked too.  I can
still manually mount the disc as root.

Steps to Reproduce:
1. Add a line to /etc/fstab to mount a CD with the "noauto,user,ro" options and
"autofs" file system.
2. Switch to normal user mode.
3. mount /mnt/cdrom
  
Actual results:
Oops: 0000 [1] SMP

Expected results:
Should have mounted the disc.

Additional info:
autofs-5.0.1-0.rc2.10
Comment 1 Trevin Beattie 2006-11-21 23:45:24 EST
Sorry, I just noticed that kernel version was a typo.  It should say:
2.6.18-1.2798.fc6.x86_64
Comment 2 Jon Stanley 2008-01-07 20:48:53 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 3 Trevin Beattie 2008-01-09 21:37:56 EST
A few weeks after filing this bug I had upgraded the kernel to 2.6.18-1.2850. 
Last September I upgraded to 2.6.22.5-49.fc6.  I don't recall seeing any more
Oopses in all that time.

Note You need to log in before you can comment on or make changes to this bug.