Bug 216314 - mysql-server should be removed as a depedency
mysql-server should be removed as a depedency
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wordpress (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 01:39 EST by Daniel McNamara
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-03 13:34:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel McNamara 2006-11-19 01:39:36 EST
Description of problem:

mysql-server you be removed as a dependecy - results in unesscary bloat

Version-Release number of selected component (if applicable):


How reproducible:

Everytime

Steps to Reproduce:
1. Install wordpress from fedora extras
2. See mysql-server get dragged into depedencies
3. Sigh at extra bloat
  
Actual results:

mysql-server installed when it's not really needed

Expected results:

Dependecy to be set to what the package actually needs not whats most convenient

Additional info:

Yes in a majority of cases the mysql server will be on the same server as the
wordpress install - however like just about every mysql connecting application
it can use a remote mysql server. As such mysql-server should be removed as
dependcy as wordpress does not require it to be on the same machine.
Comment 1 John Berninger 2006-12-03 13:34:21 EST
Dependency removed in 2.0.4-3 (FE4-6) / 2.0.5-2 (FE-devel)
Comment 2 Daniel McNamara 2006-12-04 00:13:12 EST
I'm afraid it's still there - from the wordpress.spec file for 2.0.4-3

Requires: php >= 4.1.0, httpd, mysql-server, php-mysql
Comment 3 John Berninger 2006-12-05 19:49:34 EST
Drat - looks like I hit 4, 5, and devel and missed 6.  Should be updated now.
Comment 4 Daniel McNamara 2006-12-07 23:39:53 EST
Confirmed it's all good as of 2.0.4-4

Note You need to log in before you can comment on or make changes to this bug.