Bug 216321 - sarif fonts are hard to read in Thunderbird and Firefox
sarif fonts are hard to read in Thunderbird and Firefox
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: freetype (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 03:44 EST by Dirk Gfroerer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEL5-GA
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 05:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of a screen shot illustrating the problem (2.32 KB, image/png)
2006-11-19 03:44 EST, Dirk Gfroerer
no flags Details

  None (edit)
Description Dirk Gfroerer 2006-11-19 03:44:40 EST
Description of problem:


RHEL 5 Beta 2

xorg-x11-fonts-Type1-7.1-2.1.el5
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.1.el5
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5
xorg-x11-fonts-100dpi-7.1-2.1.el5
xorg-x11-fonts-truetype-7.1-2.1.el5
xorg-x11-fonts-75dpi-7.1-2.1.el5
xorg-x11-fonts-base-7.1-2.1.el5
xorg-x11-fonts-misc-7.1-2.1.el5

How reproducible:
Everytime.

Steps to Reproduce:
1. Launch firefox.
2. Navigate to e.g. http://www.heise.de/newsticker
3. Take a look at the page being rendered.
  
Actual results:
Page is hard to read. Charactersequences like e.g. al are glued together.

Expected results:
Page is easy to read as it used to be with RHEL 4.
Comment 1 Dirk Gfroerer 2006-11-19 03:44:40 EST
Created attachment 141578 [details]
Part of a screen shot illustrating the problem
Comment 2 Matthias Clasen 2006-11-19 20:14:54 EST
core X fonts are pretty irrelevant here, since firefox uses pango for rendering.
Reassigning to freetype.
Comment 3 Alexei Podtelezhnikov 2007-02-07 15:51:17 EST
-- uses pango.. reassigning to freetype...  
-- huh? why not pango?
Comment 4 Alexei Podtelezhnikov 2007-04-05 19:01:26 EDT
This bug should be closed by now. firefox/pango updates had fixed it like more 
than a month ago
Comment 5 Matěj Cepl 2007-04-06 08:46:40 EDT
Reporter, could you please confirm comment 4?
Comment 6 Dirk Gfroerer 2007-04-10 04:16:48 EDT
Yes, this seems to be fixed in RHEL 5 final.

Note You need to log in before you can comment on or make changes to this bug.