Bug 216327 - sealert should let me delete multiple alerts at once
sealert should let me delete multiple alerts at once
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 05:44 EST by Nils Philippsen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 01:18:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2006-11-19 05:44:27 EST
Description of problem:

Currently, I can only delete a single alert at a time. When there are numerous
individual (and sometimes only slightly) different alerts, tidying up becomes
tedious, even more so because you need to confirm each delete action.

Version-Release number of selected component (if applicable):

setroubleshoot-1.0-1

How reproducible:

Reproducible.

Steps to Reproduce:
1. Delete AVC alerts
2. one
3. at
4. a
5. time
6. and become really bored ;-)
Comment 1 John Dennis 2006-11-20 10:43:31 EST
Agreed, the current mechanism is tedious and it will be fixed. FWIW, my plan is
to model it after an IMAP email client, anything you select for deletion is
marked for deletion, but actual delete does not occur till "purge". Deleted
items will appear with a "strike-through" font. Multiple alerts would be able to
be selected for any operation (delete being just one operation). I was also
plannign on adding a control-D keyboard shortcut for deletion.

The reason for the two step delete process is to protect against unintended
deletions (there would be a menu item to undelete) and to get rid of that
obnoxious "do you really want to delete" dialog box.

In the new model you could select as many items as you wish and then mark them
for deletion. It does require 1 extra step, purge. I think this solves both
problems, mass deletions are easier and the "don't shoot yourself in the foot"
protection is less obnoxious. If its not difficult I may consider adding a "hide
deleted alerts" menu item in keeping with emulating the IMAP mail client model.

Comment 2 Nils Philippsen 2006-11-21 10:08:12 EST
Sounds well :-).
Comment 3 John Dennis 2006-11-28 01:18:26 EST
all features described in comment #1 are now implemented and will appear in the
1.8 version.

Note You need to log in before you can comment on or make changes to this bug.