Bug 216345 - Windows missing decorations for unpriv user and other desktop anomalies
Windows missing decorations for unpriv user and other desktop anomalies
Status: CLOSED DUPLICATE of bug 212725
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
6
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-19 13:18 EST by Steve Schaeffer
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 10:22:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of errant display (572.99 KB, application/octet-stream)
2006-11-19 13:18 EST, Steve Schaeffer
no flags Details

  None (edit)
Description Steve Schaeffer 2006-11-19 13:18:19 EST
Description of problem:
Desktop display windows have no decorations and don't create buttons in bottom
panel. Workplace Switcher also does not display properly. This appears to be a
privilege problem as the desktop behaves normally for "root."

The attached screenshot shows problems. It was difficult to run more than 1
application as most of them display in the upper-left corner of the screen,
overlaying the desktop menus.

I'm not sure this is a Nautilus problem but the only error messages that show up
upon exiting X that are unique to the unprivileged user are:

** (nautilus:pid):WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS
** (nautilus:pid):WARNING **: Can not get _NET_WORKAREA
** (nautilus:pid):WARNING **: Can not determine workarea, gussing at layout

The only difference in the Xorg log is that these lines are at the end of the
non-priv user's log:

(II) SAVAGE(0): [drm] removed 1 reserved context for kernel
(II) SAVAGE(0): [drm] unmapping 8192 bytes of SAREA 0xeebf1000 at 0xb0eb5000

Version-Release number of selected component (if applicable):
Every package is the latest available.

How reproducible:
Every login/startx for non-root account

Additional info:
This started after applying the following set of updates:
 Packages Installed:
    pygobject2-doc.i386 2.12.2-2.fc6
 
 Packages Updated:
    foomatic.i386 3.0.2-39.1.fc6
    oprofile.i386 0.9.2-3.fc6
    gnome-python2-canvas.i386 2.16.2-1.fc6
    hal-cups-utils.i386 0.6.2-4.2
    pygobject2-devel.i386 2.12.2-2.fc6
    pygobject2.i386 2.12.2-2.fc6
    nautilus.i386 2.16.2-5.fc6
    xorg-x11-xinit.i386 1.0.2-15.fc6
    nautilus-extensions.i386 2.16.2-5.fc6
    sysstat.i386 7.0.0-2.fc6
    gnome-python2-gnomevfs.i386 2.16.2-1.fc6
    gnome-python2.i386 2.16.2-1.fc6
    oprofile-gui.i386 0.9.2-3.fc6
    libsoup.i386 2.2.97-1.fc6
    gnome-python2-gconf.i386 2.16.2-1.fc6
    gnome-python2-bonobo.i386 2.16.2-1.fc6
Comment 1 Steve Schaeffer 2006-11-19 13:18:19 EST
Created attachment 141590 [details]
Screenshot of errant display
Comment 2 Alexander Larsson 2006-11-20 10:37:08 EST
It seems you are not running a window manager.
Comment 3 Steve Schaeffer 2006-11-20 11:00:36 EST
(In reply to comment #2)
> It seems you are not running a window manager.
> 

How would I have done that? I'm not aware of any action on my part that would
have created this situation. Remember, this does not happen to the root user.
How do I find out for sure? Then, what do I do about it?

I also meant to mention that I'm only seeing this on the Athlon box and not on
an x86_64 or VMware VM install that I've done.
Comment 4 Steve Schaeffer 2006-11-20 21:27:47 EST
OK, figured it out. You are correct that no window manager was running. What 
happened was I tried to Enable Desktop Effects (switch to compiz) and the 
whole UI locked up... no screen, no keyboard, no mouse. I had to ssh in from 
another system and reboot to restore sanity. This coincided with the package 
updates cited above and I incorrectly associated the actions.

I restored normal display behavior with: metacity --replace gconf &

I then tried: compiz --replace gconf &
and that trashed everything again so I rebooted and restored metacity as above.

I'm not changing the status/flags on this report as I'm assuming you'll want 
to pursue the problems with compiz. I'll be happy to help if I can.
Comment 5 Søren Sandmann Pedersen 2006-11-21 10:22:47 EST

*** This bug has been marked as a duplicate of 212725 ***

Note You need to log in before you can comment on or make changes to this bug.