Bug 216346 - Enigmail XPI from MozDev site crashes Thunderbird on x86_64
Enigmail XPI from MozDev site crashes Thunderbird on x86_64
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-11-19 13:36 EST by Russell Odom
Modified: 2008-01-15 09:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 09:38:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Odom 2006-11-19 13:36:20 EST
Description of problem:
Thunderbird 1.5.x crashes on x84_64 with the Enigmail X86_64 0.94.0 XPI. This
worked on FC4/TB1.0.x.

How reproducible: Every time; unfortunately I can't see any debug messages that
would help diagnosis.

Steps to Reproduce:
1. Install the x86_64 XPI from http://enigmail.mozdev.org/download.html
2. Restart Thunderbird
3. Try to do something with Enigmail, e.g. view a PGP-signed message

Additional info:
I'm not entirely sure whether this is a problem with Thunderbird; more likely I
think that this should be a package included in Fedora Extras (apologies if this
is the wrong place to request this), since the Mozdev site explicitly states
that their builds are only for official Thunderbird builds. Mandriva do this
with their mozilla-thunderbird-enigmail package, Suse includes it in their
standard Thunderbird package, and Debian also provide a package.

http://enigmail.mozdev.org/source.html has instructions for compiling your own XPI.

http://forums.mozillazine.org/viewtopic.php?t=485173 has another report from
someone else with the same problem.
Comment 1 David Monniaux 2006-11-21 04:36:46 EST
Same problem here.

In addition, compiling one's own XPI is totally nonobvious: my compilation fails
due to mysterious g++ errors:
/usr/bin/ld: nsEnigModule.o: relocation R_X86_64_PC32 against
`NS_NewGenericModule2(nsModuleInfo const*, nsIModule**)' can not be used when
making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
Comment 2 Remi Collet 2006-12-24 16:17:19 EST
This is a "visibility" problem.

(re)building thunderbird with "ac_cv_visibility_pragma=no" is a workaround which
solved this issue (allowing to build enigmail or to use the available xpi).

Hope that's help.
Comment 3 Russell Odom 2007-01-09 03:52:55 EST
Related: bug 175451

Remi Collet (comment 2) has built an RPM of Thunderbird with Enigmail at
http://remi.collet.free.fr/index.php?2006/12/24/269-thunderbird-with-enigmail-on-fc6-x86_64
- merci Remi!
Comment 4 Remi Collet 2007-05-05 09:28:46 EDT
This bug also affects ppc and thunderbird 2.0.0.0

Regards
Comment 5 Trever Adams 2007-09-26 03:26:26 EDT
I see this hasn't been addressed in a while. Enigmail is a good plugin that is
certainly needed for those who don't wish to use Evolution. It would be nice if
Fedora had enigmail and lightning, or at least worked with them.
Comment 6 Matěj Cepl 2007-12-10 04:23:28 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 7 Matěj Cepl 2008-01-15 09:38:26 EST
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

{This is mass-closing of all obsolete bugs; if this bug was in your opinion
closed by mistake, please, reopen it with additional information; thanks a lot
and I am sorry for bothering you in such case.}

Note You need to log in before you can comment on or make changes to this bug.