Bug 216371 - mkfs on dm-crypt device backed by loop device hangs system
Summary: mkfs on dm-crypt device backed by loop device hangs system
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Milan Broz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-20 01:07 UTC by Robin Green
Modified: 2013-03-01 04:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 17:18:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robin Green 2006-11-20 01:07:08 UTC
Description of problem:
I tried to create a dm-crypt device backed by a file (via /dev/loop3), but when
trying to make a filesystem on it, the system kept crashing.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2849.fc6

How reproducible:
Always

Steps to Reproduce:
losetup /dev/loop3 baslag.img
cryptsetup -y -c aes-cbc-essiv:sha256 create home /dev/loop3
mkfs.ext3 -b 4096 /dev/mapper/home
  
Actual results:
System hangs at "Writing superblocks and filesystem accounting information: " or
earlier; X hangs, and progs run from serial console hang too. No printks on
serial console; no messages found in /var/log after reboot, either.

Expected results:
No system hang.

Additional info:
A minimal kernel built from kernel.org version 2.6.18.3 does not exhibit this issue.

Comment 1 Milan Broz 2007-12-09 17:18:50 UTC
This problem should be solved in 2.6.24-rc kernels (in Fedora rawhide).

For more information see http://bugzilla.kernel.org/show_bug.cgi?id=8020 .



Note You need to log in before you can comment on or make changes to this bug.