Bug 216422 - gnome session terminates on system idle
gnome session terminates on system idle
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 06:37 EST by QingLong
Modified: 2013-03-05 22:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 07:37:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description QingLong 2006-11-20 06:37:31 EST
Description of problem:
Gnome session is terminated (by g-p-m, I guess) when system is idle for a while

Version-Release number of selected component (if applicable):
2.16.0-3.fc6

How reproducible:
100%

Steps to Reproduce:
1. Activate gnome-power-manager in gnome session.
2. Leave the system alone to let it become ``idle'' and wait for a while
   (half an hour should be enough).

Actual results:
Gnome session is terminated, gconfd sends to syslog:
      Received signal 15, shutting down cleanly

Expected results:
Should hibernate/suspend/do nothing depending on g-p-m configuration.

Additional info:
I have tried to set action_sleep_type to `nothing' and even totally disable
ac_sleep_computer and ac_sleep_display (set them to 0),
but that changed nothing.

Don't know if this is related to screensaver,
nevertheless here is some info on the stuff.
The screensaver is gnome-screensaver-2.16.1-2.fc6.i386.                        
                                                                   
Other screensaver related packages installed on the system:
   libXScrnSaver-1.1.0-3.1.i386
   libXScrnSaver-devel-1.1.0-3.1.i386
   xscreensaver-base-5.01-3.fc6.i386
   xscreensaver-extras-5.01-3.fc6.i386
   xscreensaver-extras-gss-5.01-3.fc6.i386
   xscreensaver-gl-extras-5.01-3.fc6.i386
   xscreensaver-gl-extras-gss-5.01-3.fc6.i386
Comment 1 QingLong 2006-11-21 03:27:59 EST
I had killed gnome-power-manager by hand and gnome session has survived this night.
So I think that is gnome-power-manager that caused those session terminations.
Comment 2 QingLong 2006-11-23 07:37:47 EST
I hope I have found out the real problem matter.
It looks like those session terminations have been caused by Xserver crash
which in turn have been caused by "nvidia" proprietary driver instability.
It had been accidentally crashed by some GL screensavers and g-p-m.
After I have switched to the original Xorg "nv" driver
the problem has gone.
So I think this bug thread should be closed here.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.