Bug 216439 - system-config-kickstart crash when there is NO Internet connection available
system-config-kickstart crash when there is NO Internet connection available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 09:48 EST by Nicolas Scheibling
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 13:53:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Scheibling 2006-11-20 09:48:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Description of problem:
If there is no Internet connection available on the host where system-config-kickstart run, system-config-kickstart crash.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.6.17-1.fc6

How reproducible:
Always


Steps to Reproduce:
1.Use a host on a private subnet without any Internet routing
2.run system-config-kickstart


Actual Results:
Wait a few seconds, and s-c-k crash.

Expected Results:
s-c-k should work and permit the ks file configuration.

Additional info:
[root@LinuxFC6-NSC system-config-kickstart]# system-config-kickstart 
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=i386 error was
[Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=core-6&arch=i386 error was
[Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
system-config-kickstart requires either the base or development yum repository enabled for package selection.  Please enable one of these in /etc/yum.repos.d and restart the program.
[root@LinuxFC6-NSC system-config-kickstart]# rpm -q system-config-kickstart 
system-config-kickstart-2.6.17-1.fc6
[root@LinuxFC6-NSC system-config-kickstart]# rpm -q pykickstart
pykickstart-0.36-1
Comment 1 Chris Lumens 2006-11-20 13:53:55 EST
Okay, committed a fix to disable the package selection screen if there are
problems downloading yum repo information.  This will be in the next build of
s-c-kickstart for rawhide and will probably be released as an FC-6 update.
Comment 2 Nicolas Scheibling 2006-11-23 09:22:52 EST
Hi, 
why disabling the package selection screen ? 

What will happend if i want to configure a kickstart file (and select packages)
to use with the official CD/DVD Release as install media ? 

Disabling package selection if there is no Internet connection, will result to a
lost of functionalities.
Comment 3 Chris Lumens 2006-11-27 10:14:51 EST
Because s-c-kickstart uses pirut to provide that screen, and if pirut cannot
access the repodata then it's going to crash like you were seeing.  We can't
just make up a set of packages for that screen, so disabling it if there are
problems with the underlying system is really the only way to go.

Note You need to log in before you can comment on or make changes to this bug.