Bug 21649 - USEPEERDNS=YES crept back into initscripits
USEPEERDNS=YES crept back into initscripits
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-03 10:48 EST by Henri Schlereth
Modified: 2014-03-16 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-03 21:04:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2000-12-03 10:48:39 EST
USEPEERDNS is again set to yes which means that ifup-ppp rewrites resolve.conf and eliminates the
nameserver settings and replaces them with the ISP's DNS. This effectively kills internal DNS resolves
when using RFC1918 IP's for example.
Comment 1 Bill Nottingham 2000-12-03 19:26:35 EST
Yes. Is there a reason you can't unset it in your case?
Comment 2 Henri Schlereth 2000-12-03 21:04:50 EST
Of course I set it back, but can you give me any good reason why I had to do that? I dont consider it a feature if it over writes my
resolve.conf with DNS entries that I dont need/use. The ifup-ppp should be an rpmnew. I was upgrading a server that provides services for
six internal machines not a  standalone dial-up workstation. My DNS servers knows how to talk to the ISP DNS servers without
them being in resolv.conf.  This has never been an endearing feature since it was instituted. It may be wonderfull and helpful to
the helpless but not to the rest of us.
Comment 3 Bill Nottingham 2000-12-03 21:08:32 EST
ifup-ppp should not be made into an rpmnew file; it's not a config file.
In fact, it probably shouldn't even be marked %config.

To turn off support for this, set PEERDNS=no in whatever ifcfg-<interface>
file you're using.

Note You need to log in before you can comment on or make changes to this bug.