Bug 2165304 - libcxx-16.0.2 is available
Summary: libcxx-16.0.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libcxx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tulio Magno Quites Machado Filho
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-01-29 07:54 UTC by Upstream Release Monitoring
Modified: 2023-05-05 01:28 UTC (History)
6 users (show)

Fixed In Version: libcxx-16.0.2-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-05 01:28:41 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Upstream Release Monitoring 2023-01-29 07:54:04 UTC
Releases retrieved: 16.0.0-rc1
Upstream release that is considered latest: 16.0.0-rc1
Current version/release in rawhide: 15.0.7-2.fc38
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 1 Upstream Release Monitoring 2023-01-29 07:54:08 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-02-08 12:53:36 UTC
Releases retrieved: 16.0.0-rc2
Upstream release that is considered latest: 16.0.0-rc2
Current version/release in rawhide: 15.0.7-2.fc38
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 3 Upstream Release Monitoring 2023-02-08 12:53:39 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 4 Upstream Release Monitoring 2023-02-23 06:29:21 UTC
Releases retrieved: 16.0.0-rc3
Upstream release that is considered latest: 16.0.0-rc3
Current version/release in rawhide: 15.0.7-2.fc38
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 5 Upstream Release Monitoring 2023-02-23 06:29:24 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 6 Upstream Release Monitoring 2023-03-11 12:55:22 UTC
Releases retrieved: 16.0.0-rc4
Upstream release that is considered latest: 16.0.0-rc4
Current version/release in rawhide: 15.0.7-2.fc38
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 7 Upstream Release Monitoring 2023-03-11 12:55:25 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 8 Upstream Release Monitoring 2023-03-17 23:34:41 UTC
Releases retrieved: 16.0.0
Upstream release that is considered latest: 16.0.0
Current version/release in rawhide: 15.0.7-2.fc38
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 9 Upstream Release Monitoring 2023-03-17 23:34:44 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 10 Upstream Release Monitoring 2023-04-06 12:42:05 UTC
Releases retrieved: 16.0.1
Upstream release that is considered latest: 16.0.1
Current version/release in rawhide: 16.0.0-1.fc39
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 11 Upstream Release Monitoring 2023-04-06 12:42:09 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 12 Upstream Release Monitoring 2023-04-20 07:13:08 UTC
Releases retrieved: 16.0.2
Upstream release that is considered latest: 16.0.2
Current version/release in rawhide: 16.0.1-1.fc39
URL: http://libcxxabi.llvm.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/11491/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libcxx

Comment 13 Upstream Release Monitoring 2023-04-20 07:13:11 UTC
Scratch build failed. Details below:

DownloadException: The specfile contains a Source URL with an unknown protocol; it shouldbe "https", "http", or "ftp".
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 164, in build
    new_sources = self._spec_sources(specfile, tmp)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 337, in _spec_sources
    raise DownloadException(msg)

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 14 Fedora Update System 2023-04-28 00:36:14 UTC
FEDORA-2023-67a2776b08 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-67a2776b08

Comment 15 Fedora Update System 2023-04-28 13:10:10 UTC
FEDORA-2023-67a2776b08 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2023-05-02 17:56:55 UTC
FEDORA-2023-fac2a3fb5f has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-fac2a3fb5f

Comment 17 Fedora Update System 2023-05-03 01:23:50 UTC
FEDORA-2023-fac2a3fb5f has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-fac2a3fb5f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-fac2a3fb5f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2023-05-05 01:28:41 UTC
FEDORA-2023-fac2a3fb5f has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.