Bug 216615 - gnome-screensaver fails to unlock screen if kerberos in use; segfaults on x86_64
Summary: gnome-screensaver fails to unlock screen if kerberos in use; segfaults on x86_64
Status: CLOSED DUPLICATE of bug 216718
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-21 08:39 UTC by Stephan Wiesand
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 06:45:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephan Wiesand 2006-11-21 08:39:26 UTC
Description of problem:
We're using Kerberos 5 for authentication (and AFS homed directories, if it
matters). With the current pam/krb5 configuration on EL5 beta2, the following
all work as expected:
 - login (gdm)
 - login (console)
 - login (ssh, password)
 - login (ssh, gssapi)
 - kinit, aklog
 - kscreensaver (even does the right thing - refreshs my credentials)

However, gnome-screensaver fails to unlock the screen. Having turned on
debugging for the pam_krb5afs module, I see a success message in the log
for every unlock attempt:

gnome-screensaver-dialog: pam_krb5[4638]: authentication succeeds for ...

On x86_64 only, I see in addition:

kernel: gnome-screensav[8260]: segfault at 0000003456a26730 rip 0000003456a26730
rsp 0000000040a000b8 error 14

On x86, it fails silently.

Accounts with a local password don't have this problem

Version-Release number of selected component (if applicable):

gnome-screensaver-2.16.1-2.el5.x86_64
gnome-screensaver-2.16.1-2.el5.i386

How reproducible:
100%

Comment 1 Ray Strode [halfline] 2006-11-21 19:40:08 UTC
Hi, does

 rpm -e pkinit-nss  

work around the problem for you?

Comment 2 Stephan Wiesand 2006-11-22 05:55:00 UTC
Hi, yes it does. Unlocking the screen works, no more segfaults.

Comment 3 Ray Strode [halfline] 2006-11-22 06:45:44 UTC

*** This bug has been marked as a duplicate of 216718 ***


Note You need to log in before you can comment on or make changes to this bug.