Bug 21665 - mail with '+' doesn't seem to work...
mail with '+' doesn't seem to work...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-03 17:55 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 23:55:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-03 17:55:38 EST
I tried registrering as "simon+redhat@josefsson.org" and entered my
bug report, and everything looked fine but when I pressed "commit" it 
complained that "simon@josefsson.org" wasn't a registrered user.

Registrering as "simon@josefsson.org" instead worked...
Comment 1 n0dalus 2005-11-27 07:32:24 EST
I didn't have any problems registering as n0dalus+redhat@gmail.com...
I do have problems however, with some URLs in bugzilla that don't encode '+'
properly (as %2B).

An example of this is on my 'Front page', where the link for bugs assigned to me is:
https://bugzilla.redhat.com/bugzilla//buglist.cgi?bug_status=UNCONFIRMED&bug_status=ASSIGNED&bug_status=NEW&emailassigned_to1=1&emailtype1=exact&email1=n0dalus+redhat%40gmail.com

The + in the url is interpreted (correctly) as a space, so it says it can't find
any user with my name. Proper url encoding should fix this.
Comment 2 David Lawrence 2006-04-08 13:50:02 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 3 n0dalus 2006-04-08 22:25:34 EDT
I haven't tried to verify the original poster's bug, but the bug I mentioned in
comment #1 is still there.
Comment 4 David Lawrence 2006-04-10 23:55:11 EDT
Should be fixed now. The URL in the 2nd comment will need to be recreated though
from the advanced query page to take advantage of the fix.

Note You need to log in before you can comment on or make changes to this bug.