Bug 216668 - nscd core nscd-2.3.4-2.25 x86_64
Summary: nscd core nscd-2.3.4-2.25 x86_64
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc   
(Show other bugs)
Version: 4.4
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-21 14:38 UTC by Vojtech Moravek
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 10:20:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vojtech Moravek 2006-11-21 14:38:32 UTC
Description of problem:
NSCD service crashed while after start on 64bit x86_64 platform.
Time from start to crash nscd service is max 1 hour.  

Strange messsage is after next start "nscd -d" on first debug row. 
"invalid persistent database file "/var/db/nscd/passwd": verification failed"

I did try swith off option with "peristent passwd no". Withou any result on
function. 

Version-Release number of selected component (if applicable):
RHEL 4.u4
nscd-2.3.4-2.25
glibc-2.3.4-2.25 

Environment:
Openldap with 10000 users.
Samba server use ldap DB.
nscd provide passwd and group cache.

How reproducible:


Steps to Reproduce:
1.x86_64 arhitecture
2.wait a while

  
Actual results:


Expected results:


Additional info:
Servers runing on 32bit architecture with same configuration and same RHEL with
updates haven't this problem - nscd run correcly.

I will try create core dump, or sent strace output.

Comment 1 Ulrich Drepper 2006-11-21 15:39:44 UTC
The "invalid daatabase" might just be a consequence of the crash.  And everytime
the ldap nss module is involved chances are more than good that it is the problem.

Can you reproduce this with a better implemented NSS module?  Use NIS, it's
known to work.

Comment 2 Jakub Jelinek 2006-11-21 15:48:44 UTC
Also, can you reproduce it with http://people.redhat.com/jakub/glibc/2.3.4-2.29/
(didn't get through QA yet, but for testing should be usable)?
There have been multiple nscd bugfixes since RHEL4 U4.

Comment 3 Jakub Jelinek 2007-03-19 10:20:51 UTC
Please retry with RHEL4.5 beta (glibc-2.3.4-2.36 or above) and reopen if the
problem still persists.


Note You need to log in before you can comment on or make changes to this bug.