Bug 216674 - dbus-1.0.1-1.fc6 needs /var/lib/dbus directory
dbus-1.0.1-1.fc6 needs /var/lib/dbus directory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 09:46 EST by Sammy
Modified: 2013-03-05 22:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:54:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2006-11-21 09:46:52 EST
Description of problem:

After installing dbus from the fc6-testing and restarting system
you get an error message at dbus initialization saying that it cannot
create /var/lib/dbus/machine-id. This is because the directory /var/lib/dbus
does not exist.

Creating /var/lib/dbus and restarting solves problem. I guess the rpm
should creter/own this directory.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Case 2006-12-01 05:16:06 EST
Created /var/lib/dbus; but still got the following error after restarting.

process 20182: D-Bus library appears to be incorrectly set up; failed to read
machine uuid: Failed to open "/var/lib/dbus/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.
Initializing nautilus-search-tool extension
Initializing nautilus-open-terminal extension
Comment 2 Bill Case 2006-12-01 05:28:39 EST
Sorry; I mis-spoke.  I had logged out and in and got the above error.  When I
actually RESTARTED, everything worked fine.

Regards Bill
Comment 3 Michal Jaegermann 2006-12-01 11:36:04 EST
I am getting the same error when restarting.  This is actually
a re-appearance of bug 214027 (but the other was for rawhide and
is closed there).
Comment 4 John (J5) Palmieri 2006-12-01 13:26:38 EST
Building new version which owns the /var/lib/dbus directory so it is created on
install
Comment 5 John (J5) Palmieri 2006-12-01 18:02:44 EST
Should be in the next update
Comment 6 Bug Zapper 2008-04-04 00:51:01 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2008-05-06 12:54:05 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.