Bug 216677 - install devours memory when the kickstart keyword repo is used
install devours memory when the kickstart keyword repo is used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 09:53 EST by stef
Modified: 2008-03-05 19:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 19:05:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stef 2006-11-21 09:53:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)

Description of problem:
when you create in the kickstart an entry with the new keywords 'repo' to use extras repositories, the install devours the memory eventualy leading to a crash.

added this in the ks.cfg I use, I have a server mirroring the fedora ones

repo --name=core --baseurl=http://yum/fedora/linux/core/6/i386/os/
repo --name=updates --baseurl=http://yum/fedora/linux/core/updates/6/i386/
repo --name=extras --baseurl=http://yum/fedora/linux/extras/6/i386/
repo --name=livna --baseurl=http://yum/livna/6/i386/



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.configure repos in ks.cfg
2.start install, crashes at around 80-85% of install
3.

Actual Results:
crashes at around 80-85% of install

Expected Results:
installs

Additional info:
Comment 1 Chris Lumens 2006-11-21 11:08:24 EST
Please attach the error message you are receiving to this bug.  Also, what
package selections are you making in the %packages section of your kickstart file?
Comment 2 stef 2006-11-21 11:36:21 EST
just the install crashing red screen scrolling fast with rpmdb errors

rpmdb: PANIC: fatal region error detected; run recovery error: db4

Here's the %packages section

%packages
@base
@base-x
@admin-tools
@gnome-software-development
@development-tools
@development-libs
@x-software-development
@gnome-desktop
@web-server
@mysql
@office
@sound-and-video
@system-tools
@legacy-software-development
@legacy-software-support
@editors
@graphics
@text-internet
@ruby
@authoring-and-publishing
@graphical-internet
@french-support
@engineering-and-scientific
libXp
-gaim
-xchat
Comment 3 Jeremy Katz 2006-11-28 13:10:02 EST
How much memory does your machine have?
Comment 4 stef 2006-11-29 03:54:24 EST
The box where it happens has 1Gb RAM and I configured kickstart to create a 2Gb
SWAP partition on disk
Comment 5 Orion Poplawski 2006-12-01 17:58:25 EST
I seem to be seeing this as well on a 512MB Core 2 Duo Latitude D620.

I've had successful installs with this same kickstart file on other machines
before now though.  Maybe we've just finally grown big enough to cause problems...
Comment 6 Orion Poplawski 2006-12-01 18:22:30 EST
I'm not sure it's a memory issue though.  anaconda process size does grow for a
while when installing packages (as seen by top), to around 25%, but gets down to
about 3-5% again by the time of the crash.  Unless that is really just showing
the anaconda process being slowing push to swap?  

May just be a frail rpmdb (again)?  I've been seeing problems on a box upgraded
from FC5.
Comment 7 Orion Poplawski 2006-12-01 19:00:35 EST
Okay, free is now showing 141632k swap used, so memory is an issue.
Comment 8 David Cantrell 2007-03-15 18:28:45 EDT
Is this still happening with rawhide or a Fedora 7 test release?
Comment 9 Orion Poplawski 2007-03-26 12:18:01 EDT
(In reply to comment #8)
> Is this still happening with rawhide or a Fedora 7 test release?

Hard to test for a couple reasons:

- immediate but fixable: bug #231543 - multiple repositories are currently broken.

- harder - I didn't notice this problem until FC6 had been in production for a
while the the updates repo had gotten to an appreciable size.  Not sure how to
similate this for testing.
Comment 10 Orion Poplawski 2007-05-23 16:03:08 EDT
I filed a new bug #241062, but I guess it's really a duplicate of this one, but
it points out the cause.  rpms are building up in /tmp/cache/<repo>/packages and
filling up ram.  This is why it showed up after fc6 had been released one enough
updates got released.

Note You need to log in before you can comment on or make changes to this bug.