Bug 216688 - adp94xx device probe fails at install time if HostRAID config is present
adp94xx device probe fails at install time if HostRAID config is present
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
Depends On:
Blocks: 217115 221441
  Show dependency treegraph
Reported: 2006-11-21 10:43 EST by Kimball Murray
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-11 16:30:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Remove asd_attach_Host_RAID parameter from driver (1.06 KB, patch)
2006-11-21 10:43 EST, Kimball Murray
no flags Details | Diff

  None (edit)
Description Kimball Murray 2006-11-21 10:43:43 EST
Description of problem:
When running a RHEL4 install on a machine with a HostRAID configuration +
adp94xx driver, the install fails because the adp94xx driver needs a module
parameter to allow the HostRAID setup.

Version-Release number of selected component (if applicable):
RHEL4 U4 (and probably earlier)

How reproducible:

Steps to Reproduce:
1. Run RHEL4.4 installation on system described above
Actual results:
device probe aborts because it requires a module parameter to be set.

Expected results:
adp94xx should load and installation should succeed.

Additional info:
The adp94xx module seems to work fine for Stratus in the HostRAID config.  We
are not sure why there is a module parameter (asd_attach_Host_RAID), which when
not set causes the device probe to abort.  Also, the RHEL5 replacement to this
driver (aic94xx) does not have a similar parameter.  The best answer may be to
remove the parameter from the driver.
Comment 1 Kimball Murray 2006-11-21 10:43:44 EST
Created attachment 141777 [details]
Remove asd_attach_Host_RAID parameter from driver
Comment 2 D. Stimits 2006-11-21 16:37:07 EST
Did not want to create a duplicate of this bug...but this was tested on CentOS
4.3 and Fedora Core 6.

Hardware is a Tyan add-on card, the m9000-10, which uses the AIC-9410W chip:

The install phase properly detects and loads the adp94xx driver. However, drives
attached to this are not visible and the system is unable to use any drive
attached. This is true for both SAS and SATA drives. No parameter is able to
make the drive visible, including attach_HostRAID, or asd_attach_HOST_RAID, with
or without a ":1" argument (via the adaptec version of the driver). Various BIOS
settings were tested, with never any ability to see the drives. "The lights are
on, but nobody is home" syndrome.

This same setup works with Tyan's outdated driver (binary only) for CentOS 4.1,
which at least guarantees that the hardware functions and is installed
correctly. The outdated version of CentOS 4.1 was able to load without error
using Tyan's binary driver, which happens to load with the name adp94xx.

This same setup also works correctly if SATA drives are used via the
motherboard's integrated SATA (which sadly does not support SAS...this is what
the m9000-10 is for).

Note that the m9000-10 does not appear to have the ability to completely disable
RAID, that the host motherboard RAID can and was tested disabled/enabled. When
using the outdated Tyan-supplied driver, there was no effect when setting up
software RAID, regardless of RAID configuration (it's always a software RAID,
which ignores the m9000 RAID setting).

I can't help but feel that if the drives were known to be attached, that the
existing drivers would work (detection appears to be the only issue).
Comment 3 Kimball Murray 2006-11-28 13:45:21 EST
I think you are saying that you also tried removing the asd_attach_Host_RAID
parameter (and/or setting it to 1) and that after doing that, the driver still
failed to work?  If so, then that is a different bug.  I would still like to
remove this parameter, as it serves no real purpose.  On our hardware setup, the
driver does appear to work with the parameter removed.
Comment 4 D. Stimits 2006-11-28 21:35:49 EST
It is correct, I tried with and without asd_attach_Host_RAID, as well as similar
arguments provided by the Adaptec public documentation. The controller is
recognized just fine, but it never believes there is a drive attached. The same
is not true of the binary driver distributed by Tyan (but which only works with
a far out of date version of RHEL or SuSE)...the binary version detects drives
just fine. My guess is that the driver is very close to working right.
Comment 5 Kimball Murray 2006-12-04 15:39:42 EST
We've obtained some info from Adaptec.  Apparently the adp94xx driver runs in
non-HostRAID mode.  But that's OK for Stratus because we use it that way.  Given
that, we'd like to go forward and apply this patch so we can use this driver at
install time.

Applying this patch could surprise somebody that wanted to drive this particular
hardware in the HostRAID configuration.  The would end up with this driver being
loaded and running in non-HostRAID config, but there doesn't appear to be a
driver for this hardware in HostRAID config mode anyway.
Comment 8 Kimball Murray 2006-12-11 15:43:38 EST
Odd,  I appended a comment here before but it's gone.  Oh well.  Here goes again:

Stratus would like to declare this "not-a-bug".  After a few e-mail exchanges
with Adaptec, we learned that a BIOS utility can change the behavior of the card
so that it is detected in non-HostRAID mode.  Once that change is made, the
driver should function correctly.  We failed to discover this on our own because
apparently our BIOS is broken and it doesn't actually change anything.  Once our
BIOS is fixed, we're sure this problem will go away. Can someone set the
not-a-bug flag?  Not sure I'm allowed to do that.
Comment 9 Andrius Benokraitis 2006-12-11 16:30:33 EST
Kimball, assuming the patch no longer needs to be included, setting to CLOSED.
Comment 10 D. Stimits 2007-01-04 20:15:26 EST
Although I can't verify this due to lack of test system (the original is now in
production), the behavior from the Tyan m9000-10 would tend to agree with the
BIOS conclusion...during bootup the BIOS utility has the option to set to
non-HostRAID mode, but the setting change is ignored by the card. I have no
ability to test out if a new BIOS would solve this, but also consider it closed,
and believe the Tyan m9000-10 has the same defect as described above for other
similar hardware, probably repairable with a BIOS update.

Note You need to log in before you can comment on or make changes to this bug.