Bug 216703 - CTRL-ALT-<plus/minus> will not change screen resolution in X
CTRL-ALT-<plus/minus> will not change screen resolution in X
Status: CLOSED DUPLICATE of bug 216656
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 11:51 EST by William W. Austin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 13:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf and Xorg.0.log in gzipped tar file (5.94 KB, application/x-gzip)
2006-11-21 11:51 EST, William W. Austin
no flags Details

  None (edit)
Description William W. Austin 2006-11-21 11:51:53 EST
Description of problem:
Immediately after the install, I tried the CTRL-ALT-plus seq. to try to change
resolution - it did not work.  I put up with it as I was going to install the
nvidia drivers anyway.  After installing them the same problem still exists -
change resolution while running X only by using xvidtune.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-47.1.fc6 (x86_64), kernel-2.6.18-1.2849, glibc-2.5-3


How reproducible:
Always

Steps to Reproduce:
1.startx
2.CTRL-ALT-PLUS (or MINUS)
3.
  
Actual results:
No change in screen resolution

Expected results:
Screen resolution should change to next (previous) resolution in
/etc/X11/xorg.conf for current screen depth.

Additional info:
Have been X developer (and contributor) since R5 (and XFree86) and still am. 
Went through all docs and have found no referenced change.  Assumed that someone
had set a default equivalent to 'Option "DontZoom" "True"' so added 'Option
"DontZoom" "False"'.  It doesn't help.
If I boot back to my fc5 partition, the problem goes away.  Config files are
essentially the same except for minor diffs to module path.
This is not a show stopper but is a pain.
Am attaching /etc/X11/xorg.conf and Xorg.0.log in gzipped tar file 
(Could this be a "security" change?)
Comment 1 William W. Austin 2006-11-21 11:51:56 EST
Created attachment 141789 [details]
/etc/X11/xorg.conf and Xorg.0.log in gzipped tar file
Comment 2 William W. Austin 2006-11-21 11:53:28 EST
In case it not clear, the same bug occurs identically whether I use the default
"nv" driver or the 3rd part "nvidia" driver.
Comment 3 William W. Austin 2006-11-27 01:11:50 EST
After a lot more investigation the problem seems to be that on the number keypad
only the "Num Lock" and "Enter" keys are recognized under fc6 (on this keyboard,
anyway).  If I boot back to the fc5 partition, they are recognized just fine
under X11.  The xorg.conf files are essentially identical except for the
necessary difference in module path (/usr/lib64/xorg/modules vs.
/usr/X11R6/lib64/modules + /usr/X11R6/lib/modules).

The problem is also definitely independent of whether I use stock ('nv') driver
or closed-source 'nvidia' driver - identical results with either.

Tried swapping keyboards with identical results (this kbd works fine on another
fc5 machine I have here and the kbd from that box shows the same problem under
fc6 although it works fine on the fc5 machine).

In text (non-X) mode, the numeric keypad works fine on both fc5 and fc6.

FWIW, in X, xkeycaps cannot detect presses from any of the "ignored" keys in the
numeric keypad (no xevents): '/', '*', '-', '[0-9]', '+', '.' .  Yep, only enter
and numlock are detected - have tried 3 different kbds with same results from all 3.



Comment 4 Will Woods 2006-12-01 13:27:27 EST
I think this is a duplicate of the other resolution-switching bugs. Once the
fixed X server is available, please test it out. If that doesn't fix the
problem, feel free to reopen this bug.

*** This bug has been marked as a duplicate of 216656 ***
Comment 5 William W. Austin 2006-12-01 19:51:38 EST
(In reply to comment #4)
> I think this is a duplicate of the other resolution-switching bugs. Once the
> fixed X server is available, please test it out. If that doesn't fix the
> problem, feel free to reopen this bug.
> 
> *** This bug has been marked as a duplicate of 216656 ***

I am a bit concerned because of two major differences between the bugs:

A) The entire number keypad is dead here, not just the +/- keys (although they
were what made me notice it to begin with).
B) Also this is nvidia, not radeon, and the same thing occurs with either the
"normal" nv driver or the NIVIDIA "nvidia" driver.  That seems a touch significant.

Otherwise I hope it works.

Note You need to log in before you can comment on or make changes to this bug.